summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-05-23 19:33:54 +0300
committerMart Raudsepp <leio@gentoo.org>2017-05-23 19:34:44 +0300
commitcaa0d3685ae6bf9fd60bbfc3311d64499cd1d778 (patch)
tree6fda5e8984f05c9231e187b3f5cde04b0d43fc68 /x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.22.0-r2.ebuild
parentdev-python/cffi: depend on virtual/pkgconfig (diff)
downloadgentoo-caa0d3685ae6bf9fd60bbfc3311d64499cd1d778.tar.gz
gentoo-caa0d3685ae6bf9fd60bbfc3311d64499cd1d778.tar.bz2
gentoo-caa0d3685ae6bf9fd60bbfc3311d64499cd1d778.zip
x11-themes/adwaita-icon-theme: fix corrupted send-to-symbolic.svg
This icon is used at least in gnome-maps "What's here" popup, where it's displaying a missing image icon without the fix. Gentoo-bug: 616220 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.22.0-r2.ebuild')
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.22.0-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.22.0-r2.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.22.0-r2.ebuild
new file mode 100644
index 000000000000..fe30a6548f6f
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.22.0-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg:2
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-send-to-symbolic.patch
+)
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}