summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 16:08:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 21:33:09 +0100
commit4b20a852f5a6da035070bcab11cc5b1dc5e7ec00 (patch)
treead6045afd78133f053b4b908d75630acb40a017a /x11-themes/adwaita-qt
parentdev-python/zope-configuration: 4.3.1 bump (diff)
downloadgentoo-4b20a852f5a6da035070bcab11cc5b1dc5e7ec00.tar.gz
gentoo-4b20a852f5a6da035070bcab11cc5b1dc5e7ec00.tar.bz2
gentoo-4b20a852f5a6da035070bcab11cc5b1dc5e7ec00.zip
x11-themes/adwaita-qt: Switch to cmake.eclass, fix RDEPEND, bogus BDEPEND
Closes: https://bugs.gentoo.org/705292 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-themes/adwaita-qt')
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
index bfb8d37af0b5..c290d5c603dc 100644
--- a/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
@@ -1,43 +1,45 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+
+inherit cmake
DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
-KEYWORDS="~amd64 ~ppc64 ~x86"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-
+KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="gnome"
-RDEPEND="
- gnome? ( x11-themes/QGnomePlatform )
- dev-qt/qtwidgets:5
+DEPEND="
+ dev-qt/qtcore:5
dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ gnome? ( x11-themes/QGnomePlatform )
"
-DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}"
src_configure() {
BUILD_DIR="${WORKDIR}/${PN}_qt5"
local mycmakeargs=( -DUSE_QT4=OFF )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
local _d
for _d in "${WORKDIR}"/${PN}_qt*; do
- cmake-utils_src_compile -C "${_d}"
+ cmake_src_compile -C "${_d}"
done
}
src_install() {
local _d
for _d in "${WORKDIR}"/${PN}_qt*; do
- cmake-utils_src_install -C "${_d}"
+ cmake_src_install -C "${_d}"
done
}