summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-03-26 21:17:26 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-03-26 23:03:23 +0200
commitb0c6d7f80f76ab914eec4e71efd7bcadc44e47ad (patch)
treea49b9888602a6e97a3200c31ad0f6c51315edb36 /x11-themes/arc-icon-theme/arc-icon-theme-20161122.ebuild
parentmedia-video/makemkv: Version bump to 1.10.5, remove old 1.10.4 (diff)
downloadgentoo-b0c6d7f80f76ab914eec4e71efd7bcadc44e47ad.tar.gz
gentoo-b0c6d7f80f76ab914eec4e71efd7bcadc44e47ad.tar.bz2
gentoo-b0c6d7f80f76ab914eec4e71efd7bcadc44e47ad.zip
x11-themes/arc-icon-theme: version bump 20160605 → 20161122
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-themes/arc-icon-theme/arc-icon-theme-20161122.ebuild')
-rw-r--r--x11-themes/arc-icon-theme/arc-icon-theme-20161122.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-themes/arc-icon-theme/arc-icon-theme-20161122.ebuild b/x11-themes/arc-icon-theme/arc-icon-theme-20161122.ebuild
new file mode 100644
index 000000000000..35794ca1a065
--- /dev/null
+++ b/x11-themes/arc-icon-theme/arc-icon-theme-20161122.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils
+
+DESCRIPTION="Vertex icon theme"
+HOMEPAGE="https://github.com/horst3180/arc-icon-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# Require adwaita until moka is packaged
+RDEPEND="
+ x11-themes/adwaita-icon-theme
+"
+DEPEND=""
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}