summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-02-26 23:34:46 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-02-26 23:34:46 +0000
commitc8ea5fa65a7cbdb9f59ed77547d95392bbb29e9d (patch)
treeb1cddb5e11bb9b636a31974cc9670f72018f0a81 /x11-themes/arc-theme
parentdev-util/patchelf: Drop old 0.13 (diff)
downloadgentoo-c8ea5fa65a7cbdb9f59ed77547d95392bbb29e9d.tar.gz
gentoo-c8ea5fa65a7cbdb9f59ed77547d95392bbb29e9d.tar.bz2
gentoo-c8ea5fa65a7cbdb9f59ed77547d95392bbb29e9d.zip
x11-themes/arc-theme: Version bump to 20220223
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-themes/arc-theme')
-rw-r--r--x11-themes/arc-theme/Manifest1
-rw-r--r--x11-themes/arc-theme/arc-theme-20220223.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 44994f18f5af..3fe23c70d9a0 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -3,3 +3,4 @@ DIST arc-theme-20210412.tar.xz 257248 BLAKE2B c525c3632670d8aa6b640baa8b3dddca6c
DIST arc-theme-20211018-pngs.tar.xz 160836 BLAKE2B 4c2882ce03724c7abd8d4db31da82355d28b792a16648e010eca033f77d3ad6da8f7026e2562249caa993f2e8549191b6ec8d4473fbcab084ae3d91c468956c5 SHA512 6ac7bf27ebc258d0e2c2102ed286ba196d6f9c8343e1885d77d8f29cda0f8c247926003bd8c40165e08b9b3987f8a2f82800d509b78dd598d2e7ff8bea964831
DIST arc-theme-20211018.tar.xz 271084 BLAKE2B dc8808a5c7a0444d5ac11fa213b99b9633691ad920a07820752974f98febd8bc112a34568c38d354558e7876182278603ab66ebf8e50aa51f5eba431bd6b3433 SHA512 da46efc0e38efb7f1d0cd9a5d2c4e8f00f3b8d408ec50c54d89ef67fc3bb5ea253b5fb890b0cb8e82cafebd44a599d0de2369272ed88da73dd979052b130bd55
DIST arc-theme-20220105.tar.xz 342432 BLAKE2B 37a4e196fbbe532e4f9036681770fb90843c8a4645b8218c471f2f5f68e7c0c07107a71698634a61553ba4f22f483a336b113ff6906fed48c0285a67321d0896 SHA512 dc2a1e1dad03fd187e8e571b752e52d73c7cbed24f3228f1782c4a4897b1085e2466f6f8373af32d650ad9835df3ad19a1206f3fa55d543115092aa46118e31f
+DIST arc-theme-20220223.tar.xz 343044 BLAKE2B 7bdd3689eae270a97d5405c2eaf523b9d81284c1860d39de5f46a7c32d75dd24f745a5264d76625c08c2185ad87e65a99e93d39be753dc0304a86daa863df3cd SHA512 33a0e73e9951fcfe74f80af5e1449df23a5564d11a26b930cbc17b0f74887aedf2634579da1e0484e22465422f62559c801dbcd35221fbb7b7fc783671103aa4
diff --git a/x11-themes/arc-theme/arc-theme-20220223.ebuild b/x11-themes/arc-theme/arc-theme-20220223.ebuild
new file mode 100644
index 000000000000..dddb29af6aa3
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20220223.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="A flat theme with transparent elements for GTK 2/3/4 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 +gtk4 mate +transparency xfce"
+
+GLIB_DEPEND="dev-libs/glib"
+SASSC_DEPEND="dev-lang/sassc"
+
+# Supports various GTK, GNOME Shell, and Cinnamon versions and uses
+# --version option for gnome-shell and cinnamon to determine which set of files to build.
+# Updates will therefore break existing installs but there's no way around this.
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.56.0
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.28
+ )
+ gtk3? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+ gtk4? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_configure() {
+ # Cinnamon still uses metacity themes for its window manager.
+ # so we enable metacity theme too if USE=cinnamon
+ # but only enable metacity if USE=mate
+ local themes=$(
+ printf "%s," \
+ $(usev cinnamon "cinnamon metacity") \
+ $(usev gnome-shell) \
+ $(usev gtk2) \
+ $(usev gtk3) \
+ $(usev gtk4) \
+ $(! use cinnamon && usev mate metacity) \
+ $(usev xfce xfwm)
+ )
+
+ local emesonargs=(
+ -Dthemes="${themes%,}"
+ $(meson_use gnome-shell gnome_shell_gresource)
+ $(meson_use transparency)
+ )
+
+ meson_src_configure
+}