summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-19 23:56:42 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-19 23:56:42 +0200
commitb63f14b8737284d34486fbec74dedf47e4c2f5e0 (patch)
tree528142d00be5aa4d411c2fea7ca813ec2c30d7e9 /x11-themes/blueglass-xcursors
parentdev-libs/libuv: Version 1.33.1 (diff)
downloadgentoo-b63f14b8737284d34486fbec74dedf47e4c2f5e0.tar.gz
gentoo-b63f14b8737284d34486fbec74dedf47e4c2f5e0.tar.bz2
gentoo-b63f14b8737284d34486fbec74dedf47e4c2f5e0.zip
x11-themes/blueglass-xcursors: Port to EAPI 7
Bug: https://bugs.gentoo.org/697134 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/blueglass-xcursors')
-rw-r--r--x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild
index 3b72b7eb69a9..737c68f7943c 100644
--- a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild
+++ b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
MY_P="5532-BlueGlass-XCursors-3D-${PV}"
+
DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
HOMEPAGE="http://www.kde-look.org/content/show.php?content=5532"
SRC_URI="http://kde-look.org/content/files/$MY_P.tar.bz2"
@@ -11,17 +12,16 @@ SRC_URI="http://kde-look.org/content/files/$MY_P.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P:5}"
# Note: although the package name is BlueGlass, the tarball & authors directions
# use the directory 'Blue'.
src_install() {
- dodir /usr/share/cursors/xorg-x11/Blue/cursors/
- cp -R "${WORKDIR}"/${MY_P:5}/Blue/cursors "${D}"/usr/share/cursors/xorg-x11/Blue/ || die
- dodoc "${WORKDIR}"/${MY_P:5}/README
+ insinto /usr/share/cursors/xorg-x11/Blue
+ doins -r Blue/cursors
+
+ einstalldocs
}
pkg_postinst() {
@@ -33,14 +33,15 @@ pkg_postinst() {
einfo "Xcursor.size: 48"
einfo ""
einfo "To globally use this set of mouse cursors edit the file:"
- einfo " /usr/share/cursors/xorg-x11/default/index.theme"
+ einfo " ${EROOT}/usr/share/cursors/xorg-x11/default/index.theme"
einfo "and change the line:"
einfo " Inherits=[current setting]"
einfo "to"
einfo " Inherits=Blue"
einfo ""
einfo "Note this will be overruled by a user's ~/.Xdefaults file."
- einfo ""
+ einfo
+
ewarn "If you experience flickering, try setting the following line in"
ewarn "the Device section of your XF86Config:"
ewarn "Option \"HWCursor\" \"false\""