summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-11 00:00:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-11 00:19:39 +0100
commitf992e6e040601a9622a5008a9e51efce89a62dc3 (patch)
tree380e0130e2816d17936001e9fe245e1f892abb59 /x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild
parentgames-roguelike/stone-soup: Add 0.26.0 in new slot (diff)
downloadgentoo-f992e6e040601a9622a5008a9e51efce89a62dc3.tar.gz
gentoo-f992e6e040601a9622a5008a9e51efce89a62dc3.tar.bz2
gentoo-f992e6e040601a9622a5008a9e51efce89a62dc3.zip
x11-themes/elementary-xfce-icon-theme: Bump to 0.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild
new file mode 100644
index 000000000000..4ae67eb35126
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils toolchain-funcs
+
+MY_P="${PN%-icon-theme}-${PV}"
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/elementary-xfce/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="media-gfx/optipng
+ sys-apps/findutils
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ # delete dangling doc links
+ find -L "${D}" -type l -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}