summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gartoon/gartoon-0.5-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gartoon/gartoon-0.5-r2.ebuild')
-rw-r--r--x11-themes/gartoon/gartoon-0.5-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-themes/gartoon/gartoon-0.5-r2.ebuild b/x11-themes/gartoon/gartoon-0.5-r2.ebuild
new file mode 100644
index 000000000000..1472de283deb
--- /dev/null
+++ b/x11-themes/gartoon/gartoon-0.5-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Gartoon SVG icon theme"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="amd64 ~ppc sparc ~x86"
+SLOT="0"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ mydest="/usr/share/icons/${PN}"
+}
+
+src_prepare() {
+ sed -e "s:\(^pixmap_path\) \(\".*\"$\):\1 \"${mydest}/scalable/stock\":" \
+ -i scalable/stock/iconrc || die "sed failed"
+}
+
+src_install() {
+ insinto ${mydest}
+ doins index.theme scalable/stock/iconrc
+
+ dodoc AUTHORS README scalable/stock/changelog_mula.txt
+
+ for dir in apps devices emblems filesystems mimetypes stock; do
+ cd "${S}"/scalable/${dir}
+ insinto ${mydest}/scalable/${dir}
+ for svg in *svg; do
+ doins ${svg}
+ done
+ done
+
+ dosym gnome-lockscreen.svg ${mydest}/scalable/apps/xfce-system-lock.svg
+ dosym control-center2.svg ${mydest}/scalable/apps/xfce-system-settings.svg
+ dosym gnome-logout.svg ${mydest}/scalable/apps/xfce-system-exit.svg
+ dosym mozilla-firefox.svg ${mydest}/scalable/apps/firefox-icon.svg
+ dosym gnome-globe.svg ${mydest}/scalable/apps/firefox-icon-unbranded.svg
+}