summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2017-02-24 14:33:16 +0100
committerAndreas K. Huettel <dilfridge@gentoo.org>2017-02-28 21:22:47 +0100
commit1aeff5b4226b306c71c7b652d8b309e77f01f890 (patch)
treeaed9f828c399a29093bf5a605b7998a3f831be9b /x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
parentdev-ml/ocaml-ctypes: arm stable, bug #607034 (diff)
downloadgentoo-1aeff5b4226b306c71c7b652d8b309e77f01f890.tar.gz
gentoo-1aeff5b4226b306c71c7b652d8b309e77f01f890.tar.bz2
gentoo-1aeff5b4226b306c71c7b652d8b309e77f01f890.zip
x11-themes/leonidas-backgrounds: EAPI bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild')
-rw-r--r--x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
new file mode 100644
index 000000000000..b0030ad298dc
--- /dev/null
+++ b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=12
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F11_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!x11-themes/fedora-backgrounds:11"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+src_unpack() {
+ rpm_src_unpack
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ dodoc Credits
+
+ insinto /usr/share/backgrounds/leonidas
+ doins -r leonidas* landscape lion
+
+ insinto /usr/share/gnome-background-properties
+ doins desktop-*.xml
+}