summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-11-10 21:41:57 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2016-12-08 16:30:29 +0100
commitd1b23afd8d72ed5c225a2d688164b5d80516d352 (patch)
tree5253f596a9f23f6aba863d10ad3656199762f440 /x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.16.0.ebuild
parentmate-base/mate-applets: version bump to 1.16.0 (diff)
downloadgentoo-d1b23afd8d72ed5c225a2d688164b5d80516d352.tar.gz
gentoo-d1b23afd8d72ed5c225a2d688164b5d80516d352.tar.bz2
gentoo-d1b23afd8d72ed5c225a2d688164b5d80516d352.zip
x11-themes/mate-icon-theme-faenza: version bump to 1.16.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.16.0.ebuild')
-rw-r--r--x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.16.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.16.0.ebuild b/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.16.0.ebuild
new file mode 100644
index 000000000000..d8a9d7503ff6
--- /dev/null
+++ b/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.16.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Faenza icon theme, that was adapted for MATE desktop"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="minimal"
+
+RDEPEND="x11-themes/hicolor-icon-theme:0
+ !minimal? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"
+
+RESTRICT="binchecks strip"
+
+# https://github.com/mate-desktop/mate-icon-theme-faenza/issues/13
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Remove broken libreoffice icons (dangling symlinks).
+ rm matefaenza/apps/16/*libreoffice* || die
+
+ mate_src_prepare
+}