summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-26 11:40:21 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:49:00 -0400
commit25712354c679a714db3b4837dedafc84d162e1ed (patch)
tree01ea4d0b4aca8050a51fb7465712f4831c63595d /x11-themes/mate-themes
parentmate-extra/caja-hide: Add new package, caja-extension (diff)
downloadgentoo-25712354c679a714db3b4837dedafc84d162e1ed.tar.gz
gentoo-25712354c679a714db3b4837dedafc84d162e1ed.tar.bz2
gentoo-25712354c679a714db3b4837dedafc84d162e1ed.zip
x11-themes/mate-themes: Bump to 3.22.21
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-themes/mate-themes')
-rw-r--r--x11-themes/mate-themes/Manifest1
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.19.ebuild2
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.21.ebuild37
3 files changed, 39 insertions, 1 deletions
diff --git a/x11-themes/mate-themes/Manifest b/x11-themes/mate-themes/Manifest
index c1f403e08ad7..64732a78a94c 100644
--- a/x11-themes/mate-themes/Manifest
+++ b/x11-themes/mate-themes/Manifest
@@ -1 +1,2 @@
DIST mate-themes-3.22.19.tar.xz 5567828 BLAKE2B 8eeead9b097e2a9e76aac849e6b6fe93382a6ff6dbdf4bd3b032167744fdf35ff047cdb85d1480474e1f0fc0f06ceda04e7d9e4a6ae573b04cd78c4e4ca858f7 SHA512 3e8a5a37bb6755c65da3307957569e84cce546c9786396f5eb8cb5f84ddf64e04260b87f67cb0b03c7c7dc13b4f75790fb9afe8b971101f3556ee6c015bb585d
+DIST mate-themes-3.22.21.tar.xz 5377276 BLAKE2B 2efa2ab47440baa869da02fe8b65bc05a91ac79ab5d5794c182a05af736c4593b07c8c1ff9dde6b770462ad208d426565a7a07e359ee62ebc50ec7e737eaa7e5 SHA512 5f0e7e1f688e02a5c9581ec8f552da836a4c4355caa853650a19b670971acbecc3a4ac32aa7fb282879fd5a48e0a3e4aed5d182054fe2e9bb1270c74bfcef5bc
diff --git a/x11-themes/mate-themes/mate-themes-3.22.19.ebuild b/x11-themes/mate-themes/mate-themes-3.22.19.ebuild
index f88a2fd4a654..98ed6123a2c9 100644
--- a/x11-themes/mate-themes/mate-themes-3.22.19.ebuild
+++ b/x11-themes/mate-themes/mate-themes-3.22.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
diff --git a/x11-themes/mate-themes/mate-themes-3.22.21.ebuild b/x11-themes/mate-themes/mate-themes-3.22.21.ebuild
new file mode 100644
index 000000000000..10b46ff615eb
--- /dev/null
+++ b/x11-themes/mate-themes/mate-themes-3.22.21.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+MATE_GTK_V="$(ver_cut 1-2)"
+
+HOMEPAGE="https://mate-desktop.org"
+DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
+SRC_URI="https://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/${MATE_GTK_V}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-2:2
+ >=x11-themes/gtk-engines-2.15.3:2
+ x11-themes/gtk-engines-murrine
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/autoconf-2.53
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ virtual/pkgconfig
+"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ eautoreconf
+}