summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-30 04:46:42 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-30 04:47:51 +1100
commit8e93d8def981b18e27be7714f197947e36fd2810 (patch)
treeee5b5c32499fb7d1914663157357c3a1fd7d5592 /x11-themes/smplayer-themes/smplayer-themes-15.6.0.ebuild
parentmedia-video/smplayer: restore ppc keyword (diff)
downloadgentoo-8e93d8def981b18e27be7714f197947e36fd2810.tar.gz
gentoo-8e93d8def981b18e27be7714f197947e36fd2810.tar.bz2
gentoo-8e93d8def981b18e27be7714f197947e36fd2810.zip
x11-themes/smplayer-themes: version bump
Also ensure that rcc is called from the correct directory (bug #544108) and fix parallel build (bug #544160). Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-themes/smplayer-themes/smplayer-themes-15.6.0.ebuild')
-rw-r--r--x11-themes/smplayer-themes/smplayer-themes-15.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/smplayer-themes/smplayer-themes-15.6.0.ebuild b/x11-themes/smplayer-themes/smplayer-themes-15.6.0.ebuild
new file mode 100644
index 000000000000..01065b0c5f7c
--- /dev/null
+++ b/x11-themes/smplayer-themes/smplayer-themes-15.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="Icon themes for smplayer"
+HOMEPAGE="http://smplayer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ # bug 544108
+ sed -i -e "s| rcc| \"$(qt4_get_bindir)\"/rcc|" themes/Makefile || die
+
+ # bug 544160
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+}
+
+src_install() {
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}