summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/tangerine-icon-theme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/tangerine-icon-theme')
-rw-r--r--x11-themes/tangerine-icon-theme/Manifest2
-rw-r--r--x11-themes/tangerine-icon-theme/metadata.xml5
-rw-r--r--x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild52
3 files changed, 59 insertions, 0 deletions
diff --git a/x11-themes/tangerine-icon-theme/Manifest b/x11-themes/tangerine-icon-theme/Manifest
new file mode 100644
index 000000000000..31415cbe9abf
--- /dev/null
+++ b/x11-themes/tangerine-icon-theme/Manifest
@@ -0,0 +1,2 @@
+DIST gentoo-logo.svg 13764 SHA256 ad81a212991cd24faaddbc260c806c805fd7a67f65b24655908a8971fa10794e SHA512 c89df6fad432dfbbed921c4828ff22b9ea5b8930f403ad23e867a11d98764488dddc453b6f26503f9f6dc25b8c5a387b7cc91c17a6b5cee15c4aadafe76409c1 WHIRLPOOL 4b37d15450c3e1ac0b1080d3beab4e106a065e49cba9eaa0565c1090f5fa498a4d92023a7745df639126870edfdabe6c32e849a888409f2f60707e51adb7dea1
+DIST tangerine-icon-theme_0.27.tar.gz 1163543 SHA256 4842f55143694a4d5b12517ff0b53d3dac1a67413b32c4a46bbf1b4b805f5489
diff --git a/x11-themes/tangerine-icon-theme/metadata.xml b/x11-themes/tangerine-icon-theme/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/x11-themes/tangerine-icon-theme/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
new file mode 100644
index 000000000000..31ab16006995
--- /dev/null
+++ b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="a derivative of the standard Tango theme, using a more orange approach"
+HOMEPAGE="http://packages.ubuntu.com/gutsy/x11/tangerine-icon-theme"
+SRC_URI="mirror://ubuntu/pool/universe/t/${PN}/${PN}_${PV}.tar.gz
+ http://www.gentoo.org/images/gentoo-logo.svg"
+
+LICENSE="CC-BY-SA-2.5 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="minimal"
+
+RESTRICT="binchecks strip"
+
+RDEPEND="!minimal? ( || ( x11-themes/gnome-icon-theme kde-apps/oxygen-icons ) )"
+DEPEND="dev-util/intltool
+ >=gnome-base/librsvg-2.34
+ sys-devel/gettext
+ >=x11-misc/icon-naming-utils-0.8.90"
+
+DOCS="AUTHORS README"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:lib/icon-naming-utils/icon:libexec/icon:' \
+ Makefile || die
+
+ cp "${DISTDIR}"/gentoo-logo.svg scalable/places/start-here.svg || die
+
+ local res
+ for res in 16 22 32; do
+ rsvg-convert -w ${res} -h ${res} scalable/places/start-here.svg \
+ > ${res}x${res}/places/start-here.png || die
+ done
+}
+
+src_compile() {
+ emake index.theme
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }