summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/vdrgraphtft-avp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/vdrgraphtft-avp')
-rw-r--r--x11-themes/vdrgraphtft-avp/Manifest1
-rw-r--r--x11-themes/vdrgraphtft-avp/metadata.xml10
-rw-r--r--x11-themes/vdrgraphtft-avp/vdrgraphtft-avp-0.3.1.ebuild40
3 files changed, 51 insertions, 0 deletions
diff --git a/x11-themes/vdrgraphtft-avp/Manifest b/x11-themes/vdrgraphtft-avp/Manifest
new file mode 100644
index 000000000000..28c293d2b7c7
--- /dev/null
+++ b/x11-themes/vdrgraphtft-avp/Manifest
@@ -0,0 +1 @@
+DIST alien-vs-predator-0.3.1.tar.bz2 5357940 SHA256 0687f6d3da8fe2466a09bba9da3960a02a591e63a05862b3580c1d05d53221f3 SHA512 253b532f3f4ae147bc136985f9f4390da7de1191af0c12882142c6dfa01fe0a6e5b74eb3270e47827a7b7f027447ad20caace8d5d353095548e59c15bc8a9817 WHIRLPOOL aa043153291e250a881a003f8f901f4a033df120840e2da8c13a065d1925fef3338a10bf1c3da2677edc478097c7fc1430cc25cd93e096c634b0dcf1b6a8b591
diff --git a/x11-themes/vdrgraphtft-avp/metadata.xml b/x11-themes/vdrgraphtft-avp/metadata.xml
new file mode 100644
index 000000000000..5f9f14619db8
--- /dev/null
+++ b/x11-themes/vdrgraphtft-avp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-themes/vdrgraphtft-avp/vdrgraphtft-avp-0.3.1.ebuild b/x11-themes/vdrgraphtft-avp/vdrgraphtft-avp-0.3.1.ebuild
new file mode 100644
index 000000000000..98b164db85c8
--- /dev/null
+++ b/x11-themes/vdrgraphtft-avp/vdrgraphtft-avp-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PN="${PN/vdrgraphtft-avp/alien-vs-predator}"
+
+DESCRIPTION="GraphTFT theme: Alien vs Predator"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
+SRC_URI="http://www.jwendel.de/vdr/${MY_PN}-${PV}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ || (
+ >=media-plugins/vdr-graphtft-0.3.1
+ media-plugins/vdr-graphtftng
+ )"
+
+S="${WORKDIR}/avp"
+
+src_prepare() {
+
+ # remove dead links
+ cd "${S}"/columnimages
+ rm {srew.png,pause.png,frew1.png,frew2.png,frew3.png,play.png,ffwd1.png,ffwd2.png,ffwd3.png,sfwd.png,recOn.png}
+}
+
+src_install() {
+
+ insinto /usr/share/vdr/graphTFT/themes/avp/
+ doins -r "${S}"/*
+}