summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-21 15:54:03 -0500
committerDavid Seifert <soap@gentoo.org>2018-04-22 15:00:46 +0200
commit67873482e7d29fb310f43ab793ce8b5e53b177b0 (patch)
tree5ae872acd5cb5f26606216a0205d9b2ccf6bab09 /x11-themes/wm-icons
parentx11-themes/pulse-glass: EAPI bump (diff)
downloadgentoo-67873482e7d29fb310f43ab793ce8b5e53b177b0.tar.gz
gentoo-67873482e7d29fb310f43ab793ce8b5e53b177b0.tar.bz2
gentoo-67873482e7d29fb310f43ab793ce8b5e53b177b0.zip
x11-themes/wm-icons: EAPI bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'x11-themes/wm-icons')
-rw-r--r--x11-themes/wm-icons/files/wm-icons-0.4.0-build.patch24
-rw-r--r--x11-themes/wm-icons/wm-icons-0.4.0.ebuild22
-rw-r--r--x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild38
3 files changed, 52 insertions, 32 deletions
diff --git a/x11-themes/wm-icons/files/wm-icons-0.4.0-build.patch b/x11-themes/wm-icons/files/wm-icons-0.4.0-build.patch
new file mode 100644
index 000000000000..bd92342e1edc
--- /dev/null
+++ b/x11-themes/wm-icons/files/wm-icons-0.4.0-build.patch
@@ -0,0 +1,24 @@
+--- a/configure.in
++++ b/configure.in
+@@ -129,7 +129,7 @@ AC_OUTPUT(
+ etc/debian-menu-system/Makefile
+ devel/Makefile
+ devel/bin/Makefile
+- bin/Makefile
++
+ bin/wm-icons-config
+ doc/Makefile
+ doc/wm-icons.lsm
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -13,8 +13,8 @@ SUBDIRS = bin doc icons etc devel rpm
+ # => icondir) is different for the build and install phases, as it
+ # is for a distribution package building.
+ install-data-local:
+- # set the default icon set aliases (symlinks)
+- $(bindir)/wm-icons-config --user-dir="$(icondir)" --defaults --quiet
++# set the default icon set aliases (symlinks)
++ true --user-dir="$(icondir)" --defaults --quiet
+
+ wm-configs _pack-symlinks _unpack-symlinks:
+ cd devel/bin && $(MAKE) $(AM_MAKEFLAGS) $@
diff --git a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
index 0ab33021870c..ce4217eaf635 100644
--- a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
+++ b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
@@ -1,31 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-DESCRIPTION="A Large Assortment of Beutiful Themed Icons, Created with FVWM in mind"
+EAPI=6
+DESCRIPTION="A Large Assortment of Beautiful Themed Icons, Created with FVWM in mind"
HOMEPAGE="http://wm-icons.sourceforge.net/"
SRC_URI="mirror://sourceforge/wm-icons/wm-icons-${PV}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-
IUSE=""
+
RDEPEND="virtual/awk dev-lang/perl"
DEPEND="${RDEPEND} sys-devel/autoconf sys-devel/automake sys-apps/sed"
-src_compile() {
- econf --enable-all-sets --enable-icondir=/usr/share/icons/wm-icons || die "econf failed"
- emake || die
+src_configure() {
+ econf --enable-all-sets \
+ --enable-icondir="${EPREFIX}"/usr/share/icons/wm-icons
}
src_install() {
- make icondir="${D}/usr/share/icons/wm-icons" DESTDIR="${D}" install
+ # strange makefile...
+ emake icondir="${ED%/}/usr/share/icons/wm-icons" DESTDIR="${D}" install
einfo "Setting default aliases..."
- "${D}"/usr/bin/wm-icons-config --force --user-dir="${D}/usr/share/icons/wm-icons" --defaults
+ "${ED%/}/usr/bin/wm-icons-config" --force --user-dir="${ED%/}/usr/share/icons/wm-icons" --defaults
- dodoc AUTHORS ChangeLog NEWS README
+ einstalldocs
}
pkg_postinst() {
diff --git a/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild b/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
index 68a7e5ba3b2d..7c1741b9189e 100644
--- a/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
+++ b/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
@@ -1,52 +1,46 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit autotools
+EAPI=6
-DESCRIPTION="A Large Assortment of Beutiful Themed Icons, Created with FVWM in mind"
+inherit autotools
+DESCRIPTION="A Large Assortment of Beautiful Themed Icons, Created with FVWM in mind"
HOMEPAGE="http://wm-icons.sourceforge.net/"
SRC_URI="mirror://gentoo/wm-icons-${PV}-cvs-01092003.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 x86"
-
IUSE=""
+
RDEPEND="virtual/awk dev-lang/perl"
S=${WORKDIR}/wm-icons
-src_unpack() {
- unpack ${A}
-
- sed -i 's#$(bindir)/wm-icons-config#true#g' "${S}"/Makefile.am
- # duplication of bin/Makefile in configure.in #91764
- sed -i '132s/bin\/Makefile//' "${S}"/configure.in
- # non-portable comment bombs automake.
- sed -i 's/\t#/#/' "${S}"/Makefile.am
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-build.patch
+)
- cd "${S}"
+src_prepare() {
+ default
eautoreconf
}
-src_compile() {
- econf --enable-all-sets --enable-icondir=/usr/share/icons/wm-icons || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf --enable-icondir="${EPREFIX}"/usr/share/icons/wm-icons
}
src_install() {
# strange makefile...
- einstall icondir="${D}/usr/share/icons/wm-icons" DESTDIR="${D}" || die
+ emake icondir="${ED%/}/usr/share/icons/wm-icons" DESTDIR="${D}" install
- dodir /usr/bin
- mv "${D}"/"${D}"/usr/bin/wm-icons-config "${D}"/usr/bin/wm-icons-config
rm -rf "${D}"/var
einfo "Setting default aliases..."
- "${D}"/usr/bin/wm-icons-config --user-dir="${D}/usr/share/icons/wm-icons" --defaults
+ "${ED%/}/usr/bin/wm-icons-config" --force --user-dir="${ED%/}/usr/share/icons/wm-icons" --defaults
- dodoc AUTHORS ChangeLog NEWS README
+ einstalldocs
}
pkg_postinst() {