summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-05-31 13:12:19 +0200
committerPacho Ramos <pacho@gentoo.org>2020-05-31 14:42:18 +0200
commit00f515c1c6f5d75ecc2b94351f0e133d128060cd (patch)
tree0abdf681675c90331971d41446c7d9a8fb288ac0 /x11-themes
parentprofiles/package.mask: mask =net-ftp/proftpd-1.3.7_rc4 (diff)
downloadgentoo-00f515c1c6f5d75ecc2b94351f0e133d128060cd.tar.gz
gentoo-00f515c1c6f5d75ecc2b94351f0e133d128060cd.tar.bz2
gentoo-00f515c1c6f5d75ecc2b94351f0e133d128060cd.zip
x11-themes/QGnomePlatform: Fix build with qt-5.15
Closes: https://bugs.gentoo.org/725830 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild2
-rw-r--r--x11-themes/QGnomePlatform/files/QGnomePlatform-0.6.1-qt5.15.patch21
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild
index 65c5840ce9d0..1ec982826758 100644
--- a/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild
@@ -22,6 +22,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-qt5.15.patch" )
+
src_configure() {
eqmake5
}
diff --git a/x11-themes/QGnomePlatform/files/QGnomePlatform-0.6.1-qt5.15.patch b/x11-themes/QGnomePlatform/files/QGnomePlatform-0.6.1-qt5.15.patch
new file mode 100644
index 000000000000..b0927d12e79e
--- /dev/null
+++ b/x11-themes/QGnomePlatform/files/QGnomePlatform-0.6.1-qt5.15.patch
@@ -0,0 +1,21 @@
+From c835c9e80cfadd62e01f16591721d2103d28a212 Mon Sep 17 00:00:00 2001
+From: Jan Grulich <jgrulich@redhat.com>
+Date: Wed, 27 May 2020 13:38:49 +0200
+Subject: [PATCH] Fix build with Qt 5.15
+
+---
+ decoration/qgnomeplatformdecoration.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/decoration/qgnomeplatformdecoration.cpp b/decoration/qgnomeplatformdecoration.cpp
+index 61c2af9..c8b381c 100644
+--- a/decoration/qgnomeplatformdecoration.cpp
++++ b/decoration/qgnomeplatformdecoration.cpp
+@@ -46,6 +46,7 @@
+ #include <QtGui/QCursor>
+ #include <QtGui/QLinearGradient>
+ #include <QtGui/QPainter>
++#include <QtGui/QPainterPath>
+ #include <QtGui/QPalette>
+ #include <QtGui/QPixmap>
+