summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-04 01:16:37 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-12 21:49:21 +0100
commit61f90b73cf485940ee27e46e8e02b23c471fe4b1 (patch)
tree919b3a0be8ff7531df411dd2a417b7502b3a3372 /x11-themes
parentx11-themes/claws-mail-themes: fix eclass usage (diff)
downloadgentoo-61f90b73cf485940ee27e46e8e02b23c471fe4b1.tar.gz
gentoo-61f90b73cf485940ee27e46e8e02b23c471fe4b1.tar.bz2
gentoo-61f90b73cf485940ee27e46e8e02b23c471fe4b1.zip
x11-themes/yasis-icon-theme: move to EAPI 7
drop minimal use flag, only addded optional runtime dependency Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/yasis-icon-theme/metadata.xml10
-rw-r--r--x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2-r1.ebuild24
-rw-r--r--x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild36
3 files changed, 31 insertions, 39 deletions
diff --git a/x11-themes/yasis-icon-theme/metadata.xml b/x11-themes/yasis-icon-theme/metadata.xml
index cc1ab6847396..52c3f63cafa2 100644
--- a/x11-themes/yasis-icon-theme/metadata.xml
+++ b/x11-themes/yasis-icon-theme/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
diff --git a/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2-r1.ebuild b/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..afb44e8d8d60
--- /dev/null
+++ b/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Scalable icon theme called Yasis"
+HOMEPAGE="http://www.silvestre.com.ar/"
+SRC_URI="mirror://gentoo/yasis-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ dodoc yasis/{AUTHORS,README}
+ rm -f yasis/{AUTHORS,COPYING,DONATE,INSTALL,README}
+
+ insinto /usr/share/icons
+ doins -r yasis
+}
diff --git a/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild b/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild
deleted file mode 100644
index f14489c8268a..000000000000
--- a/x11-themes/yasis-icon-theme/yasis-icon-theme-0.4.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit xdg-utils
-
-DESCRIPTION="A scalable icon theme called Yasis"
-HOMEPAGE="http://www.silvestre.com.ar/"
-SRC_URI="http://www.silvestre.com.ar/icons/yasis-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal"
-
-RDEPEND="!minimal? ( || ( x11-themes/adwaita-icon-theme x11-themes/nuovo-icon-theme ) )"
-DEPEND=""
-
-RESTRICT="binchecks strip"
-
-S="${WORKDIR}"
-
-src_install() {
- dodoc yasis/{AUTHORS,README}
- rm -f yasis/{AUTHORS,COPYING,DONATE,INSTALL,README}
-
- insinto /usr/share/icons
- doins -r yasis
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-pkg_postrm() {
- xdg_icon_cache_update
-}