summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-07 23:04:56 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-07 23:05:19 +1100
commit66a31fecdcda5d18760de8c84c148752040b9fea (patch)
tree0157dac8173e1b4c69301cc750fde1842774e6c5 /x11-themes
parentprofiles: mask net-ftp/oneclickftp for removal (diff)
downloadgentoo-66a31fecdcda5d18760de8c84c148752040b9fea.tar.gz
gentoo-66a31fecdcda5d18760de8c84c148752040b9fea.tar.bz2
gentoo-66a31fecdcda5d18760de8c84c148752040b9fea.zip
x11-themes/smplayer-skins: revision bump
* Port to EAPI 6 * Add missing dependency * Use fully qualified Qt binaries * Fix make jobserver issue Closes: https://bugs.gentoo.org/634898 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/smplayer-skins/Manifest2
-rw-r--r--x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild32
2 files changed, 33 insertions, 1 deletions
diff --git a/x11-themes/smplayer-skins/Manifest b/x11-themes/smplayer-skins/Manifest
index 1d64949633d9..2a8c9089e3d3 100644
--- a/x11-themes/smplayer-skins/Manifest
+++ b/x11-themes/smplayer-skins/Manifest
@@ -1 +1 @@
-DIST smplayer-skins-15.2.0.tar.bz2 382879 SHA256 a73fe16f8b8802780bbac4485767f309ea8064a48e98f0b37523dc2fb7245197 SHA512 58d1dcc9caf5d93b7f0692ffa7ff4875eb8dd83db78293aee25a713a1f6007c83af556215cd1f7666dec98bc323b074c6b1fdb66eb9560176db842669c206a83 WHIRLPOOL 1a380e2bf4cfc6424c9ead4558fd93b740c52091a5c9e09facc1a4dcc44abe2510ced427243f56027bf94537151cb1e8fc0405948258fb94a1a1a8e9f72c6a08
+DIST smplayer-skins-15.2.0.tar.bz2 382879 BLAKE2B bda1e651a5f38ffb6c727634d6829d52f189af419c795ffb194fb1f38617d92f472094a600f48029bbc9882ecc0517e16745ed00d13a0a95527a0802f8bc0c05 SHA512 58d1dcc9caf5d93b7f0692ffa7ff4875eb8dd83db78293aee25a713a1f6007c83af556215cd1f7666dec98bc323b074c6b1fdb66eb9560176db842669c206a83
diff --git a/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild b/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild
new file mode 100644
index 000000000000..04a71f1d3957
--- /dev/null
+++ b/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Skins for SMPlayer"
+HOMEPAGE="https://www.smplayer.info/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ default
+
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+ sed -i -e "s|rcc -binary|$(qt5_get_bindir)/&|" themes/Makefile || die
+}
+
+src_install() {
+ rm themes/Makefile
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}