summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-30 20:49:51 +0000
committerSam James <sam@gentoo.org>2021-03-30 21:08:42 +0000
commit6f82aa02a5e0afdb2fdf7f65e2a72c55a17c5913 (patch)
tree25d8597b8d82d9f355015950b75827057780e49f /x11-themes
parentsys-process/usbtop: migrate from cmake-utils (diff)
downloadgentoo-6f82aa02a5e0afdb2fdf7f65e2a72c55a17c5913.tar.gz
gentoo-6f82aa02a5e0afdb2fdf7f65e2a72c55a17c5913.tar.bz2
gentoo-6f82aa02a5e0afdb2fdf7f65e2a72c55a17c5913.zip
x11-themes/gtk-engines-aurora: fix build with slibtool
Thanks-to: orbea <orbea@riseup.net> Closes: https://bugs.gentoo.org/779406 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-aurora/files/gtk-engines-aurora-1.5.1-slibtool-undefined-references.patch32
-rw-r--r--x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild11
2 files changed, 38 insertions, 5 deletions
diff --git a/x11-themes/gtk-engines-aurora/files/gtk-engines-aurora-1.5.1-slibtool-undefined-references.patch b/x11-themes/gtk-engines-aurora/files/gtk-engines-aurora-1.5.1-slibtool-undefined-references.patch
new file mode 100644
index 000000000000..b88f21cac82b
--- /dev/null
+++ b/x11-themes/gtk-engines-aurora/files/gtk-engines-aurora-1.5.1-slibtool-undefined-references.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/779406
+
+commit e55f6880d6bb649b2f1bd55c31bd4ba6265ccae0
+Author: orbea <orbea@riseup.net>
+Date: Tue Mar 30 11:54:33 2021 -0700
+
+ build: Fix undefined references for libm.
+
+diff --git a/Makefile.am b/Makefile.am
+index 16d29ea..09a51bb 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,4 +22,4 @@ libaurora_la_SOURCES = \
+ ./src/config.h
+
+ libaurora_la_LDFLAGS = -module -avoid-version -no-undefined
+-libaurora_la_LIBADD = $(GTK_LIBS)
++libaurora_la_LIBADD = $(GTK_LIBS) $(LIBM)
+diff --git a/configure.ac b/configure.ac
+index b1c35e9..9b446c3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,6 +20,9 @@ AC_ARG_ENABLE(animation, [ --enable-animation compile aurora with animati
+
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.10.0,,AC_MSG_ERROR([GTK+-2.10 is required to compile aurora]))
+
++AC_CHECK_LIBM
++AC_SUBST([LIBM])
++
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
diff --git a/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild b/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
index 2a8bfa1c6b8c..68deb8904145 100644
--- a/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
+++ b/x11-themes/gtk-engines-aurora/gtk-engines-aurora-1.5.1.ebuild
@@ -4,10 +4,10 @@
EAPI=7
MY_MAJ=$(ver_cut 1-2)
-
DESCRIPTION="Aurora GTK+ 2.x Theme Engine"
HOMEPAGE="https://www.gnome-look.org/content/show.php?content=56438"
SRC_URI="https://gnome-look.org/CONTENT/content-files/56438-aurora-${PV}.tar.bz2"
+S="${WORKDIR}/aurora-${MY_MAJ}"
LICENSE="GPL-2"
SLOT="0"
@@ -19,9 +19,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/aurora-${MY_MAJ}"
-
-PATCHES=( "${FILESDIR}"/${P}-glib-2.31.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-glib-2.31.patch
+ "${FILESDIR}"/${P}-slibtool-undefined-references.patch
+)
src_unpack() {
unpack ${A}
@@ -40,5 +41,5 @@ src_install() {
doins -r ../Aurora/.
# no static archives
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}