summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 11:02:59 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 11:44:27 +0100
commitca3f5b41cb0043dc1efc371bbd5b6f17a1a66afb (patch)
tree5e5d181739193095acce8cb27df661ef7b6ce9fc /x11-themes
parentx11-themes/adwaita-qt: Make repoman happier (diff)
downloadgentoo-ca3f5b41cb0043dc1efc371bbd5b6f17a1a66afb.tar.gz
gentoo-ca3f5b41cb0043dc1efc371bbd5b6f17a1a66afb.tar.bz2
gentoo-ca3f5b41cb0043dc1efc371bbd5b6f17a1a66afb.zip
x11-themes/QGnomePlatform: Bump to 0.8.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/Manifest1
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.8.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/Manifest b/x11-themes/QGnomePlatform/Manifest
index b38262d71d30..459627d71e4f 100644
--- a/x11-themes/QGnomePlatform/Manifest
+++ b/x11-themes/QGnomePlatform/Manifest
@@ -1 +1,2 @@
DIST QGnomePlatform-0.8.0.tar.gz 37381 BLAKE2B 04aeb04f08441aa4964ddb7a3f0b6afbceead82abb5399d36731c77c6de6b303a7db188094857c8346381940deeb8bcd9c6d24e0521cb10b649209e1f6b8d0a0 SHA512 e862b84024ad77976b52cbacf1f920acaa60d2bfcb8f261f1215f2e5fb2dbe6d99e10aa425be70fa2dd324ac4d8c5b85958d68fae4fb7f9728caf097aa1bd102
+DIST QGnomePlatform-0.8.1.tar.gz 38565 BLAKE2B 4b581186789990f4a2a7f96a98375185445ef57d8590495323e34875a6a08ca38e8f1e6ece7ff375867c1e126edbe2375e268f722485b29eac914a0139715a16 SHA512 d7b3253b9fcf2a1a6e320d069a6425aa78981a7f19609166b7f53fe1882e19a12fca7326265af091e6335c2ebc1f6492c5262428831e7fd8635ced23439a959f
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.8.1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.8.1.ebuild
new file mode 100644
index 000000000000..989d49dcd9e7
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ dev-qt/qtwayland:5=
+ dev-qt/qtx11extras:5=
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3[X]
+ >=x11-themes/adwaita-qt-1.4.1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ )
+ cmake_src_configure
+}