summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-02-12 09:30:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-02-12 09:31:10 +0200
commitec05bde9c339d36fa20210ebd933a77fa919f625 (patch)
tree0bf4e38f7b45628f398eb0f330fba3758a9193a8 /x11-themes
parentdev-ruby/bundler: add 2.2.9 (diff)
downloadgentoo-ec05bde9c339d36fa20210ebd933a77fa919f625.tar.gz
gentoo-ec05bde9c339d36fa20210ebd933a77fa919f625.tar.bz2
gentoo-ec05bde9c339d36fa20210ebd933a77fa919f625.zip
x11-themes/e-flat-theme: 2021-02-12 snapshot
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/e-flat-theme/Manifest1
-rw-r--r--x11-themes/e-flat-theme/e-flat-theme-0_pre20210212.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-themes/e-flat-theme/Manifest b/x11-themes/e-flat-theme/Manifest
index 1d1e6c190c57..4d66893f73e3 100644
--- a/x11-themes/e-flat-theme/Manifest
+++ b/x11-themes/e-flat-theme/Manifest
@@ -1 +1,2 @@
DIST e-flat-theme-0_pre20210121.edj 45282525 BLAKE2B baf27345585d45ca57c2826271dcd377628ef6e733ee98a06020fb4c303034bbe7866cb8704cc33361019cfb00f186839972835e9119390caf833a7a51a0cb7a SHA512 dbced249ff0fc4fd775e8c6bba524a1636f02854f7ccd42d1c038f426edea2e12c1ec677e7e1666c7a1ff74d11cbcd96c8959997dae8f8f36eb77dbcdef84822
+DIST e-flat-theme-0_pre20210212.edj 45211061 BLAKE2B 591b10cf7c2ac001fdac007903625f642d7e02ca73c9ea600b5bcb05b83e8ae2a0eff3a8b4ef0f038f6a0c1aeb3b66ea56244ad12e84b1179c426b9868acdc59 SHA512 61b3a68e1a0c60e47b6b93b9fb7a874f3b8586625eabb7f2f5c4c70c70bfe43f3325c3bc4b9fe1041866a3697511a769326dab9e424443363a81ec8a5acfe0b3
diff --git a/x11-themes/e-flat-theme/e-flat-theme-0_pre20210212.ebuild b/x11-themes/e-flat-theme/e-flat-theme-0_pre20210212.ebuild
new file mode 100644
index 000000000000..d9b011896102
--- /dev/null
+++ b/x11-themes/e-flat-theme/e-flat-theme-0_pre20210212.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern, flat theme for Enlightenment WM"
+HOMEPAGE="https://www.enlightenment.org/ https://phab.enlightenment.org/T6726"
+SRC_URI="https://dev.gentoo.org/~juippis/distfiles/${P}.edj"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+RDEPEND="x11-wm/enlightenment"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # doins doesn't allow installing straight from DISTDIR.
+ cp "${DISTDIR}"/${P}.edj . || die "Failed to prepare theme file."
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/elementary/themes/
+ newins ${P}.edj flat-0.edj
+}
+
+pkg_postinst() {
+ elog "You'll find e-flat-theme under System themes in theme selector."
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn ""
+ ewarn "You're updating flat-0 theme. Please reload Enlightenment"
+ ewarn "through Menu -> Enlightenment -> Restart, or by issuing"
+ ewarn " enlightenment -restart"
+ ewarn ""
+ fi
+}