summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-04-26 22:04:26 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-05-07 23:24:21 +0100
commitfcb7da7fe90babb7bc6d2a7bc98cfb75f9f99476 (patch)
tree3e84a7ce0465fcd5b67d08f07a8e2bf1ffaa16cf /x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild
parentx11-wm/amiwm: Take over as maintainer (diff)
downloadgentoo-fcb7da7fe90babb7bc6d2a7bc98cfb75f9f99476.tar.gz
gentoo-fcb7da7fe90babb7bc6d2a7bc98cfb75f9f99476.tar.bz2
gentoo-fcb7da7fe90babb7bc6d2a7bc98cfb75f9f99476.zip
x11-wm/amiwm: Version bump to 0.22.01_p20200826 snapshot
It has a new (but somewhat dead) upstream. I sent a bunch of patches to fix all the build issues though. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild')
-rw-r--r--x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild b/x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild
new file mode 100644
index 000000000000..7e7eaed103a1
--- /dev/null
+++ b/x11-wm/amiwm/amiwm-0.22.01_p20200826.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+COMMIT="8b8c956a904fa73edb02d4dc6d45bc0358bff3b3"
+DESCRIPTION="Amiga Workbench inspired window manager for Xorg"
+HOMEPAGE="https://github.com/redsPL/amiwm"
+SRC_URI="https://github.com/chewi/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="amiwm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMON_DEPEND="
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXext
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-fonts/font-misc-misc[nls,X]
+ x11-apps/xrdb
+ x11-apps/xsetroot
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ eautoconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" STRIPFLAG=
+ einstalldocs
+
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ exec ${PN}
+ EOF
+}