summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-11-03 20:25:10 -0400
committerTim Harder <radhermit@gentoo.org>2016-11-03 20:26:57 -0400
commit49b1414f2c9743e2a30448c6aba8871859381c6d (patch)
tree83b611dfc443a752387078e3a1d3345c19d0e3bf /x11-wm/bspwm/bspwm-0.9.2.ebuild
parentx11-misc/sxhkd: version bump to 0.5.7 (diff)
downloadgentoo-49b1414f2c9743e2a30448c6aba8871859381c6d.tar.gz
gentoo-49b1414f2c9743e2a30448c6aba8871859381c6d.tar.bz2
gentoo-49b1414f2c9743e2a30448c6aba8871859381c6d.zip
x11-wm/bspwm: version bump to 0.9.2
Diffstat (limited to 'x11-wm/bspwm/bspwm-0.9.2.ebuild')
-rw-r--r--x11-wm/bspwm/bspwm-0.9.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-wm/bspwm/bspwm-0.9.2.ebuild b/x11-wm/bspwm/bspwm-0.9.2.ebuild
new file mode 100644
index 000000000000..5e8b7bf5545c
--- /dev/null
+++ b/x11-wm/bspwm/bspwm-0.9.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Tiling window manager based on binary space partitioning"
+HOMEPAGE="https://github.com/baskerville/bspwm/"
+SRC_URI="https://github.com/baskerville/bspwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+"
+RDEPEND="${DEPEND}
+ x11-misc/sxhkd
+"
+
+src_compile() {
+ emake PREFIX=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc doc/{CONTRIBUTING,MISC,TODO}.md
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ insinto /usr/share/xsessions
+ doins contrib/freedesktop/bspwm.desktop
+
+ insinto /etc/xdg/sxhkd
+ doins examples/sxhkdrc
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}