summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/bspwm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/bspwm')
-rw-r--r--x11-wm/bspwm/Manifest2
-rw-r--r--x11-wm/bspwm/bspwm-0.8.8-r1.ebuild51
-rw-r--r--x11-wm/bspwm/bspwm-0.8.9.ebuild51
-rw-r--r--x11-wm/bspwm/files/bspwm-0.8.8-desktop.patch9
-rw-r--r--x11-wm/bspwm/files/bspwm-0.8.8-flags.patch15
-rw-r--r--x11-wm/bspwm/files/bspwm-session90
-rw-r--r--x11-wm/bspwm/metadata.xml11
7 files changed, 229 insertions, 0 deletions
diff --git a/x11-wm/bspwm/Manifest b/x11-wm/bspwm/Manifest
new file mode 100644
index 000000000000..b9e3b319acad
--- /dev/null
+++ b/x11-wm/bspwm/Manifest
@@ -0,0 +1,2 @@
+DIST bspwm-0.8.8.tar.gz 66159 SHA256 378c5e42e9058a22e519a8f727e7d078eb5945915adb6edb17e2471310e73790 SHA512 09614549410d2f6bd58d1190e8008256077433481bb4f91426fbf14ef74c3bff92f3b2d2c72476b6439ad83807c7368591af46a0c34ec658bcc5b9c6f940ca55 WHIRLPOOL 331d089c7545a5fe6325e42aa9603f9dcb81d28fd9182329dbc50a0828fafa661ce12885894d728ad99f0d04ca5a2773de257b91f62e1be3f272e0ee8a7b5674
+DIST bspwm-0.8.9.tar.gz 65604 SHA256 750c76132914661d8d5edf7809e9b601977215d31e747dd780c60fd562913d55 SHA512 77dd3d10278519bdcba02ab3309617d078428953d2944a1a5013b7ac87ae9b9c3e405760edfc78a6d740c383c8bf083598885448219f3a60e6f912389343b4f7 WHIRLPOOL dc3153b082616b44d71348b604e5f923a603b4ea75e9665c6a7ad384bafdd33da2f83da3275af671dbac614aefd953e990355cb0713504037ef57003cc46261b
diff --git a/x11-wm/bspwm/bspwm-0.8.8-r1.ebuild b/x11-wm/bspwm/bspwm-0.8.8-r1.ebuild
new file mode 100644
index 000000000000..02ef4f3c3783
--- /dev/null
+++ b/x11-wm/bspwm/bspwm-0.8.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tiling window manager based on binary space partitioning"
+HOMEPAGE="https://github.com/baskerville/bspwm/"
+SRC_URI="https://github.com/baskerville/bspwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util-wm
+"
+RDEPEND="${DEPEND}
+ x11-misc/sxhkd
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+}
+
+src_compile() {
+ emake PREFIX=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc doc/{CONTRIBUTING,MISC,TODO}.md
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ insinto /usr/share/xsessions
+ doins contrib/lightdm/bspwm.desktop
+
+ insinto /etc/xdg/sxhkd
+ doins examples/sxhkdrc
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/x11-wm/bspwm/bspwm-0.8.9.ebuild b/x11-wm/bspwm/bspwm-0.8.9.ebuild
new file mode 100644
index 000000000000..a3d22f1f9225
--- /dev/null
+++ b/x11-wm/bspwm/bspwm-0.8.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tiling window manager based on binary space partitioning"
+HOMEPAGE="https://github.com/baskerville/bspwm/"
+SRC_URI="https://github.com/baskerville/bspwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util-wm
+"
+RDEPEND="${DEPEND}
+ x11-misc/sxhkd
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.8-flags.patch
+ epatch "${FILESDIR}"/${PN}-0.8.8-desktop.patch
+}
+
+src_compile() {
+ emake PREFIX=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc doc/{CONTRIBUTING,MISC,TODO}.md
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ insinto /usr/share/xsessions
+ doins contrib/lightdm/bspwm.desktop
+
+ insinto /etc/xdg/sxhkd
+ doins examples/sxhkdrc
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/x11-wm/bspwm/files/bspwm-0.8.8-desktop.patch b/x11-wm/bspwm/files/bspwm-0.8.8-desktop.patch
new file mode 100644
index 000000000000..589a5abed893
--- /dev/null
+++ b/x11-wm/bspwm/files/bspwm-0.8.8-desktop.patch
@@ -0,0 +1,9 @@
+--- bspwm-0.8.8/contrib/lightdm/bspwm.desktop
++++ bspwm-0.8.8/contrib/lightdm/bspwm.desktop
+@@ -2,5 +2,5 @@
+ Encoding=UTF-8
+ Name=bspwm
+ Comment=Launch a bspwm session
+-Exec=/usr/bin/bspwm-session
++Exec=/etc/X11/Sessions/bspwm
+ Type=XSession
diff --git a/x11-wm/bspwm/files/bspwm-0.8.8-flags.patch b/x11-wm/bspwm/files/bspwm-0.8.8-flags.patch
new file mode 100644
index 000000000000..b0dcacac4dba
--- /dev/null
+++ b/x11-wm/bspwm/files/bspwm-0.8.8-flags.patch
@@ -0,0 +1,15 @@
+--- bspwm-0.8.8/Makefile
++++ bspwm-0.8.8/Makefile
+@@ -18,11 +18,9 @@
+ CL_SRC = bspc.c helpers.c
+ CL_OBJ = $(CL_SRC:.c=.o)
+
+-all: CFLAGS += -Os
+-all: LDFLAGS += -s
+ all: bspwm bspc
+
+-debug: CFLAGS += -O0 -g -DDEBUG
++debug: CFLAGS += -DDEBUG
+ debug: bspwm bspc
+
+ include Sourcedeps
diff --git a/x11-wm/bspwm/files/bspwm-session b/x11-wm/bspwm/files/bspwm-session
new file mode 100644
index 000000000000..e51ead1b9b54
--- /dev/null
+++ b/x11-wm/bspwm/files/bspwm-session
@@ -0,0 +1,90 @@
+#!/bin/sh
+# bspwm Xsession starter, based on Xsession from x11-apps/xinit
+
+# redirect errors to a file in user's home directory if we can
+for errfile in "$HOME/.bspwm-errors" "${TMPDIR-/tmp}/bspwm-$USER" "/tmp/bspwm-$USER"
+do
+ if ( cp /dev/null "$errfile" 2> /dev/null )
+ then
+ chmod 600 "$errfile"
+ exec > "$errfile" 2>&1
+ break
+ fi
+done
+
+userresources=$HOME/.Xresources
+usermodmap=$HOME/.Xmodmap
+userxkbmap=$HOME/.Xkbmap
+
+sysresources=/etc/X11/Xresources
+sysmodmap=/etc/X11/Xmodmap
+sysxkbmap=/etc/X11/Xkbmap
+
+rh6sysresources=/etc/X11/xinit/Xresources
+rh6sysmodmap=/etc/X11/xinit/Xmodmap
+
+# merge in defaults
+if [ -f "$rh6sysresources" ]; then
+ xrdb -merge "$rh6sysresources"
+fi
+
+if [ -f "$sysresources" ]; then
+ xrdb -merge "$sysresources"
+fi
+
+if [ -f "$userresources" ]; then
+ xrdb -merge "$userresources"
+fi
+
+# merge in keymaps
+if [ -f "$sysxkbmap" ]; then
+ setxkbmap `cat "$sysxkbmap"`
+ XKB_IN_USE=yes
+fi
+
+if [ -f "$userxkbmap" ]; then
+ setxkbmap `cat "$userxkbmap"`
+ XKB_IN_USE=yes
+fi
+
+#
+# Eeek, this seems like too much magic here
+#
+if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
+ if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
+ xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config /etc/X11/xorg.conf`
+ if [ -n "$xkbsymbols" ]; then
+ setxkbmap -symbols "$xkbsymbols"
+ XKB_IN_USE=yes
+ fi
+ fi
+fi
+
+# xkb and xmodmap don't play nice together
+if [ -z "$XKB_IN_USE" ]; then
+ if [ -f "$rh6sysmodmap" ]; then
+ xmodmap "$rh6sysmodmap"
+ fi
+
+ if [ -f "$sysmodmap" ]; then
+ xmodmap "$sysmodmap"
+ fi
+
+ if [ -f "$usermodmap" ]; then
+ xmodmap "$usermodmap"
+ fi
+fi
+
+unset XKB_IN_USE
+
+# run all system xinitrc shell scripts.
+if [ -d /etc/X11/xinit/xinitrc.d ]; then
+ for i in /etc/X11/xinit/xinitrc.d/* ; do
+ if [ -x "$i" ]; then
+ . "$i"
+ fi
+ done
+fi
+
+exec /usr/bin/sxhkd &
+exec /usr/bin/bspwm
diff --git a/x11-wm/bspwm/metadata.xml b/x11-wm/bspwm/metadata.xml
new file mode 100644
index 000000000000..5d305a00684c
--- /dev/null
+++ b/x11-wm/bspwm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">baskerville/bspwm</remote-id>
+ </upstream>
+</pkgmetadata>