summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-06 20:26:39 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-06 20:27:08 +0200
commitec4f687cf8ddf09d497dbbfdd5fae1b8dcc8574f (patch)
tree1a054fac550aa2ade96c3a11709d7d538c74028c /x11-wm/ctwm/ctwm-4.0.1.ebuild
parentnet-p2p/deluge: New version 1.3.15 (diff)
downloadgentoo-ec4f687cf8ddf09d497dbbfdd5fae1b8dcc8574f.tar.gz
gentoo-ec4f687cf8ddf09d497dbbfdd5fae1b8dcc8574f.tar.bz2
gentoo-ec4f687cf8ddf09d497dbbfdd5fae1b8dcc8574f.zip
x11-wm/ctwm: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-wm/ctwm/ctwm-4.0.1.ebuild')
-rw-r--r--x11-wm/ctwm/ctwm-4.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-wm/ctwm/ctwm-4.0.1.ebuild b/x11-wm/ctwm/ctwm-4.0.1.ebuild
new file mode 100644
index 000000000000..2e8cd8224e2c
--- /dev/null
+++ b/x11-wm/ctwm/ctwm-4.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A clean, light window manager"
+HOMEPAGE="http://ctwm.org/"
+SRC_URI="${HOMEPAGE}dist/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ app-text/rman
+ virtual/jpeg
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ default
+
+ # implicit 'isspace'
+ sed -i parse.c -e "/<stdio.h>/ a#include <ctype.h>" || die
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ mv -v "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+ mv -v "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
+}