summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-04-13 18:11:36 +0300
committerMichał Górny <mgorny@gentoo.org>2018-05-11 10:44:20 +0200
commitc13587cb8abbb4c75a5dd457b43cb52b29c3e2d7 (patch)
tree2e8a9ece254371e866d3805052c74b00a3e8f22d /x11-wm/enlightenment/enlightenment-0.20.6.ebuild
parentmedia-libs/freetype-2.9.1-r1: arm64 stable (bug #654696) (diff)
downloadgentoo-c13587cb8abbb4c75a5dd457b43cb52b29c3e2d7.tar.gz
gentoo-c13587cb8abbb4c75a5dd457b43cb52b29c3e2d7.tar.bz2
gentoo-c13587cb8abbb4c75a5dd457b43cb52b29c3e2d7.zip
x11-wm/enlightenment: disable module_check from 0.20.5 & 0.20.6
Bug: https://bugs.gentoo.org/648896 Package-Manager: Portage[mgorny]-2.3.26.1 Closes: https://github.com/gentoo/gentoo/pull/7970
Diffstat (limited to 'x11-wm/enlightenment/enlightenment-0.20.6.ebuild')
-rw-r--r--x11-wm/enlightenment/enlightenment-0.20.6.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/x11-wm/enlightenment/enlightenment-0.20.6.ebuild b/x11-wm/enlightenment/enlightenment-0.20.6.ebuild
index 0cd5bfe72614..130c64f8a4c3 100644
--- a/x11-wm/enlightenment/enlightenment-0.20.6.ebuild
+++ b/x11-wm/enlightenment/enlightenment-0.20.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,7 +13,7 @@ else
EKEY_STATE="snap"
fi
-inherit enlightenment
+inherit enlightenment xdg-utils
DESCRIPTION="Enlightenment DR17 window manager"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
@@ -57,7 +57,10 @@ RDEPEND="
>=dev-libs/efl-1.17[X]
>=media-libs/elementary-1.17
x11-libs/xcb-util-keysyms"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/automake:1.15
+"
S=${WORKDIR}/${MY_P}
@@ -91,7 +94,9 @@ check_modules() {
}
src_configure() {
- check_modules
+ # sanity check fails after commit e25cf18ca19463a7d05519aa843cc76a189ab75c
+ # see #648896. Can be restored with future release
+ # check_modules
E_ECONF=(
--disable-install-sysactions
@@ -125,3 +130,13 @@ src_install() {
insinto /etc/enlightenment
newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}