summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Turco <fturco@fastmail.fm>2018-08-26 20:08:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-11 10:03:56 +0200
commitfe6520c33d86aa869cf6e42b769370d8218ff741 (patch)
tree82d1f4b4e02874962c4b204941880d10ecd467fd /x11-wm/i3/i3-9999.ebuild
parentdev-python/llvmlite: Use parallel make for shared library (diff)
downloadgentoo-fe6520c33d86aa869cf6e42b769370d8218ff741.tar.gz
gentoo-fe6520c33d86aa869cf6e42b769370d8218ff741.tar.bz2
gentoo-fe6520c33d86aa869cf6e42b769370d8218ff741.zip
x11-wm/i3: show elog message only on first installation
Closes: https://github.com/gentoo/gentoo/pull/9703
Diffstat (limited to 'x11-wm/i3/i3-9999.ebuild')
-rw-r--r--x11-wm/i3/i3-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/x11-wm/i3/i3-9999.ebuild b/x11-wm/i3/i3-9999.ebuild
index cd758177621b..44462428862e 100644
--- a/x11-wm/i3/i3-9999.ebuild
+++ b/x11-wm/i3/i3-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -74,10 +74,14 @@ src_install() {
}
pkg_postinst() {
- einfo "There are several packages that you may find useful with ${PN} and"
- einfo "their usage is suggested by the upstream maintainers, namely:"
- einfo " x11-misc/dmenu"
- einfo " x11-misc/i3status"
- einfo " x11-misc/i3lock"
- einfo "Please refer to their description for additional info."
+
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "There are several packages that you may find useful with ${PN} and"
+ elog "their usage is suggested by the upstream maintainers, namely:"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/i3status"
+ elog " x11-misc/i3lock"
+ elog "Please refer to their description for additional info."
+ fi
}