summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-11-29 20:04:39 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-11-29 20:04:39 +0700
commita55a77655834144b9b70a89b7ec31b597abadb0c (patch)
treedb56f360a53d77a67696624f38108f4805e1ea7a /x11-wm/lumina
parentmedia-gfx/optipng: Remove vulnerable (CVE-2017-1000229) (diff)
downloadgentoo-a55a77655834144b9b70a89b7ec31b597abadb0c.tar.gz
gentoo-a55a77655834144b9b70a89b7ec31b597abadb0c.tar.bz2
gentoo-a55a77655834144b9b70a89b7ec31b597abadb0c.zip
x11-wm/lumina: bump to 1.4.0_p1
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'x11-wm/lumina')
-rw-r--r--x11-wm/lumina/Manifest1
-rw-r--r--x11-wm/lumina/lumina-1.4.0_p1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/x11-wm/lumina/Manifest b/x11-wm/lumina/Manifest
index 800254c37273..0523a2e91ba5 100644
--- a/x11-wm/lumina/Manifest
+++ b/x11-wm/lumina/Manifest
@@ -1,2 +1,3 @@
DIST lumina-1.3.0_p1.tar.gz 86451718 BLAKE2B 7834fad1541144524fc44d5e2cc1af21e82878c05f0cc2da4cf90f8f7e51614f535bab1bcb81c6d5929e14b2fa7ba7df8e66e53a9a81b55c973511f3b3e7cc17 SHA512 93fb195f26984a2ba6e62dbe1ea619e4ab8e936d1cf1d335db8a7e51058c9be8d3e389146259f8229fb5dc6477610dcc2e1278c4e2a348f27904a318ba095707
DIST lumina-1.4.0.tar.gz 22489118 BLAKE2B 547d062826a6b253cb361db3fb030c182485d335dea3baff7e30f1331c67fbffca619dbee4688f79ac04ff04e5ef2ceeae0c1146d18730a25b7d01125bc62fd3 SHA512 7243fc366a851832d9431df8ae8cac0f70a7bc92bed1282e78e5775c6593d799a07e2cac7042d770c8d6c4758bb142523027d67227a2282b47ed945b0e617cb0
+DIST lumina-1.4.0_p1.tar.gz 22489599 BLAKE2B 0c183763dae0ca046fa5d1cebc184a7ba5987113a12f72285e5dabfe25ca763683a23cb76889673ac3c2817feb2233e8b7da9fefed41040f91b0bb01d8ce03ae SHA512 340079832f4f6c9c9c70f11d7743b7c7db6772897f6411a966bf2bd77124bab1fbac8f5751164fb8a08a12c4443f515aaee76b117b4f959263eeaa98dbcbe41e
diff --git a/x11-wm/lumina/lumina-1.4.0_p1.ebuild b/x11-wm/lumina/lumina-1.4.0_p1.ebuild
new file mode 100644
index 000000000000..4bab7adf10bf
--- /dev/null
+++ b/x11-wm/lumina/lumina-1.4.0_p1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PLOCALES="af ar az bg bn bs ca cs cy da de el en_AU en_GB en_ZA es et eu fa fi fr fr_CA fur gl he hi hr hu id is it ja ka ko lt lv mk mn ms mt nb ne nl pa pl pt pt_BR ro ru sa sk sl sr sv sw ta tg th tr uk ur uz vi zh_CN zh_HK zh_TW zu"
+
+inherit qmake-utils l10n xdg-utils gnome2-utils
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="https://lumina-desktop.org/"
+SRC_URI="https://github.com/trueos/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="desktop-utils"
+
+COMMON_DEPEND="dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtsvg:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtgui:5
+ dev-qt/qtdeclarative:5
+ x11-libs/libxcb:0
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ desktop-utils? ( app-text/poppler[qt5] )"
+
+DEPEND="$COMMON_DEPEND
+ dev-qt/linguist-tools:5"
+
+RDEPEND="$COMMON_DEPEND
+ sys-fs/inotify-tools
+ x11-misc/numlockx
+ x11-wm/fluxbox
+ || ( x11-apps/xbacklight
+ sys-power/acpilight )
+ media-sound/alsa-utils
+ sys-power/acpi
+ app-admin/sysstat"
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}/1.2.0-desktop-files.patch"
+ "${FILESDIR}/1.3.0-OS-detect.patch"
+ "${FILESDIR}/1.4.0-poppler.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare(){
+ default
+
+ if use !desktop-utils ; then
+ rm -rf src-qt5/desktop-utils || die
+ sed -e "/desktop-utils/d" -i src-qt5/src-qt5.pro || die
+ fi
+
+ l10n_find_plocales_changes "${S}/src-qt5/core/${PN}-desktop/i18n" "${PN}-desktop_" '.ts'
+}
+
+src_configure(){
+ eqmake5 PREFIX="${EPREFIX}/usr" LIBPREFIX="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" CONFIG+=WITH_I18N QMAKE_CFLAGS_ISYSTEM=
+}
+
+src_install(){
+ # A hack to avoid sandbox violation and install liblthemeengine*.so to the correct places
+ emake install INSTALL_ROOT="${D}"
+ rm "${ED%/}"/${PN}-* "${ED%/}"/start-${PN}-desktop "${ED%/}"/liblthemeengine*.so "${ED%/}"/lthemeengine || die
+ mv "${D}/${D}/etc" "${D}/etc" || die
+ mv "${D}/${D}/usr/bin" "${D}/usr/bin" || die
+ mv "${D}/${D}/usr/share" "${D}/usr/share" || die
+ rm -rf "${D}/var" || die
+ mv "${ED%/}"/etc/luminaDesktop.conf{.dist,} || die
+ einstalldocs
+
+ remove_locale() {
+ rm -f "${D}"/usr/share/${PN}-desktop/i18n/l*_${1}.qm
+ }
+ l10n_for_each_disabled_locale_do remove_locale
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}