summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/mutter/files/mutter-3.14.2-automagic.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/mutter/files/mutter-3.14.2-automagic.patch')
-rw-r--r--x11-wm/mutter/files/mutter-3.14.2-automagic.patch90
1 files changed, 90 insertions, 0 deletions
diff --git a/x11-wm/mutter/files/mutter-3.14.2-automagic.patch b/x11-wm/mutter/files/mutter-3.14.2-automagic.patch
new file mode 100644
index 000000000000..3956004535a6
--- /dev/null
+++ b/x11-wm/mutter/files/mutter-3.14.2-automagic.patch
@@ -0,0 +1,90 @@
+From d723a752982e12b7a7fb7998c3e28efd9082abd9 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 8 Dec 2014 22:00:32 +0100
+Subject: [PATCH] Make wayland support optional
+
+---
+ configure.ac | 58 +++++++++++++++++++++++++++++++++++++++++++---------------
+ 1 file changed, 43 insertions(+), 15 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0870afa..251f909 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -200,23 +200,49 @@ AC_SUBST(XWAYLAND_PATH)
+
+ PKG_CHECK_MODULES(MUTTER, $MUTTER_PC_MODULES)
+
+-PKG_CHECK_MODULES(MUTTER_NATIVE_BACKEND, [clutter-egl-1.0 libdrm libsystemd libinput gbm >= 10.3], [have_native_backend=yes], [have_native_backend=no])
+-if test $have_native_backend = yes; then
+- AC_DEFINE([HAVE_NATIVE_BACKEND],[1],[Define if you want to enable the native (KMS) backend based on systemd])
+-fi
+-AM_CONDITIONAL([HAVE_NATIVE_BACKEND],[test $have_native_backend = yes])
+-
+-PKG_CHECK_MODULES(MUTTER_WAYLAND, [clutter-wayland-1.0 clutter-wayland-compositor-1.0 wayland-server >= 1.5.90], [have_wayland=yes], [have_wayland=no])
+-if test $have_wayland = yes; then
+- AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
+- AS_IF([test $WAYLAND_SCANNER = "no"],
+- AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
+- AC_SUBST([WAYLAND_SCANNER])
+-
+- AC_DEFINE([HAVE_WAYLAND],[1],[Define if you want to enable Wayland support])
+-fi
++have_wayland=no
++AC_ARG_ENABLE(
++ [wayland],
++ AS_HELP_STRING([--disable-wayland], [disable mutter on wayland support]),
++ [],
++ enable_wayland=yes
++)
++AS_IF([test "$enable_wayland" != "no"],
++ [
++ PKG_CHECK_MODULES([MUTTER_WAYLAND],
++ [clutter-wayland-1.0 clutter-wayland-compositor-1.0 wayland-server >= 1.5.90],
++ [
++ have_wayland=yes
++ AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
++ AS_IF([test $WAYLAND_SCANNER = "no"],
++ [AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols])])
++ AC_SUBST([WAYLAND_SCANNER])
++ AC_DEFINE([HAVE_WAYLAND],[1],[Define if you want to enable Wayland support])
++ ],
++ [have_wayland=no])
++])
+ AM_CONDITIONAL([HAVE_WAYLAND],[test $have_wayland = yes])
+
++have_native_backend=no
++AC_ARG_ENABLE(
++ [native-backend],
++ AS_HELP_STRING([--disable-native-backend], [disable mutter native (KMS) backend]),
++ [],
++ enable_native_backend=yes
++)
++AS_IF([test "$enable_native_backend" != "no"],
++ [
++ PKG_CHECK_MODULES([MUTTER_NATIVE_BACKEND],
++ [clutter-egl-1.0 libdrm libsystemd libinput gudev-1.0 gbm >= 10.3],
++ [
++ have_native_backend=yes
++ AC_DEFINE([HAVE_NATIVE_BACKEND],[1],
++ [Define if you want to enable the native (KMS) backend based on systemd])
++ ],
++ [have_native_backend=no])
++])
++AM_CONDITIONAL([HAVE_NATIVE_BACKEND],[test $have_native_backend = yes])
++
+ PKG_CHECK_EXISTS([xi >= 1.6.99.1],
+ AC_DEFINE([HAVE_XI23],[1],[Define if you have support for XInput 2.3 or greater]))
+
+@@ -416,6 +442,8 @@ mutter-$VERSION
+ libcanberra: ${have_libcanberra}
+ Introspection: ${found_introspection}
+ Session management: ${found_sm}
++ Wayland: ${have_wayland}
++ Native (KMS) backend: ${have_native_backend}
+ "
+
+
+--
+2.2.0
+