summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-05-17 14:27:49 +0300
committerMart Raudsepp <leio@gentoo.org>2020-05-17 14:32:02 +0300
commita15c1b8c84bc04e2273c75d36db42b704ccdcbda (patch)
tree0894f25849e667c55cd9490536d406725f9966aa /x11-wm/mutter
parentmail-filter/spamassassin: Move to EAPI=7 (diff)
downloadgentoo-a15c1b8c84bc04e2273c75d36db42b704ccdcbda.tar.gz
gentoo-a15c1b8c84bc04e2273c75d36db42b704ccdcbda.tar.bz2
gentoo-a15c1b8c84bc04e2273c75d36db42b704ccdcbda.zip
x11-wm/mutter: add patch that may fix some potential X11 crashers
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/files/3.34.6-XInitThreads.patch50
-rw-r--r--x11-wm/mutter/mutter-3.34.6-r1.ebuild146
2 files changed, 196 insertions, 0 deletions
diff --git a/x11-wm/mutter/files/3.34.6-XInitThreads.patch b/x11-wm/mutter/files/3.34.6-XInitThreads.patch
new file mode 100644
index 000000000000..f53f6ba93970
--- /dev/null
+++ b/x11-wm/mutter/files/3.34.6-XInitThreads.patch
@@ -0,0 +1,50 @@
+From 8b3f1117be1e90866747fa9c9e7ae1c5812ba918 Mon Sep 17 00:00:00 2001
+From: Daniel van Vugt <daniel.van.vugt@canonical.com>
+Date: Thu, 14 May 2020 18:13:56 +0800
+Subject: [PATCH] backend-x11: Reintroduce XInitThreads
+
+It was removed in 3.34 as part of 6ed5d2e2. And we thought that was the
+only thread that might exist and use X11. But the top gnome-shell crasher
+in 3.36 seems to suggest otherwise.
+
+We don't know what or where the offending thread is, but since:
+
+ 1. We used XInitThreads for years already prior to 3.34; and
+
+ 2. Extensions or any change to mutter/gnome-shell could conceivably use
+ threads to make X calls, directly or indirectly,
+
+it's probably a good idea to reintroduce XInitThreads. The failing assertion
+in libx11 is also accompanied by a strong hint:
+
+```
+fprintf(stderr, "[xcb] Most likely this is a multi-threaded client " \
+ "and XInitThreads has not been called\n");
+```
+
+https://bugs.launchpad.net/bugs/1877075
+
+Closes: https://gitlab.gnome.org/GNOME/mutter/-/issues/1252
+
+https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1256
+
+(cherry picked from commit 1d5f9b6917517d6e777a652cfa5e648794dc632a)
+---
+ src/backends/x11/meta-backend-x11.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/backends/x11/meta-backend-x11.c b/src/backends/x11/meta-backend-x11.c
+index 225d14d33..539ca5348 100644
+--- a/src/backends/x11/meta-backend-x11.c
++++ b/src/backends/x11/meta-backend-x11.c
+@@ -859,6 +859,7 @@ meta_backend_x11_class_init (MetaBackendX11Class *klass)
+ static void
+ meta_backend_x11_init (MetaBackendX11 *x11)
+ {
++ XInitThreads ();
+ }
+
+ Display *
+--
+2.20.1
+
diff --git a/x11-wm/mutter/mutter-3.34.6-r1.ebuild b/x11-wm/mutter/mutter-3.34.6-r1.ebuild
new file mode 100644
index 000000000000..722e7bb3d139
--- /dev/null
+++ b/x11-wm/mutter/mutter-3.34.6-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/mutter/"
+
+LICENSE="GPL-2+"
+SLOT="0/5" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
+
+IUSE="elogind input_devices_wacom +introspection screencast +sysprof systemd test udev wayland"
+# native backend requires gles3 for hybrid graphics blitting support, udev and a logind provider
+REQUIRED_USE="
+ wayland? ( ^^ ( elogind systemd ) udev )
+ test? ( wayland )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# gnome-settings-daemon is build checked, but used at runtime only for org.gnome.settings-daemon.peripherals.keyboard gschema
+# xorg-server is needed at build and runtime with USE=wayland for Xwayland
+# v3.32.2 has many excessive or unused *_req variables declared, thus currently the dep order ignores those and goes via dependency() call order
+DEPEND="
+ x11-libs/libX11
+ >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.30[introspection?]
+ >=dev-libs/fribidi-1.0.0
+ >=x11-libs/cairo-1.14[X]
+ >=gnome-base/gsettings-desktop-schemas-3.33.0[introspection?]
+ >=dev-libs/glib-2.61.1:2
+ gnome-base/gnome-settings-daemon
+ >=dev-libs/json-glib-0.12.0[introspection?]
+ gnome-base/gnome-desktop:3=
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXi-1.7.4
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=x11-libs/libxkbcommon-0.4.3[X]
+ x11-libs/libXrender
+ >=x11-libs/libXrandr-1.5.0
+ x11-libs/libxcb
+ x11-libs/libXinerama
+ x11-libs/libXau
+ x11-libs/libICE
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=media-libs/libcanberra-0.26
+ media-libs/mesa[X(+),egl]
+ wayland? (
+ >=dev-libs/wayland-protocols-1.18
+ >=dev-libs/wayland-1.13.0
+ x11-libs/libdrm:=
+ >=media-libs/mesa-10.3[egl,gbm,wayland,gles2]
+ >=dev-libs/libinput-1.4
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ x11-base/xorg-server[wayland]
+ )
+ udev? ( >=dev-libs/libgudev-232:=
+ >=virtual/libudev-232-r1:= )
+ x11-libs/libSM
+ input_devices_wacom? ( >=dev-libs/libwacom-0.13 )
+ >=x11-libs/startup-notification-0.7
+ screencast? ( >=media-video/pipewire-0.2.2:0/0.2 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ gnome-extra/zenity
+"
+DEPEND="${DEPEND}
+ x11-base/xorg-proto
+ sysprof? ( >=dev-util/sysprof-capture-3.34.1-r1:3 )
+"
+# wayland bdepend for wayland-scanner, xorg-server for cvt utility
+BDEPEND="
+ dev-libs/wayland
+ >=dev-util/meson-0.50.0
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ wayland? ( >=sys-kernel/linux-headers-4.4
+ x11-base/xorg-server )
+"
+
+PATCHES=(
+ "${FILESDIR}"/3.32-eglmesaext-include.patch
+ "${FILESDIR}"/${PV}-XInitThreads.patch
+)
+
+src_configure() {
+ # TODO: Replicate debug vs release meson build type behaviour under our buildtype=plain
+ local emesonargs=(
+ -Dopengl=true
+ #opengl_libname
+ #gles2_libname
+ $(meson_use wayland gles2)
+ -Degl=true
+ -Dglx=true
+ $(meson_use wayland)
+ $(meson_use wayland native_backend)
+ $(meson_use screencast remote_desktop)
+ -Degl_device=false # This should be dependent on wayland,video_drivers_nvidia, once eglstream support is there
+ -Dwayland_eglstream=false # requires packages egl-wayland for wayland-eglstream-protocols.pc
+ $(meson_use udev)
+ $(meson_use input_devices_wacom libwacom)
+ -Dpango_ft2=true
+ -Dstartup_notification=true
+ -Dsm=true
+ $(meson_use introspection)
+ $(meson_use test cogl_tests)
+ $(meson_use wayland core_tests) # core tests require wayland; overall -Dtests option is honored on top, so no extra conditional needed
+ $(meson_use test clutter_tests)
+ $(meson_use test tests)
+ $(meson_use sysprof profiler)
+ -Dinstalled_tests=false
+ #verbose # Let upstream choose default for verbose mode
+ #xwayland_path
+ # TODO: relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
+ #xwayland_grab_default_access_rules
+ )
+ meson_src_configure
+}
+
+src_test() {
+ glib-compile-schemas "${BUILD_DIR}"/data
+ GSETTINGS_SCHEMA_DIR="${BUILD_DIR}"/data virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}