summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-14 00:57:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 00:01:53 +0100
commitc041c9a6d1228503e15329e7eaffb24dc49c9b5b (patch)
tree531eb9f844dc7d82580ebbfaf7cc0590e2f1236f /x11-wm/openbox
parentlxde-base/menu-cache: EAPI-7 bump, fix memleak, cleanup .la (diff)
downloadgentoo-c041c9a6d1228503e15329e7eaffb24dc49c9b5b.tar.gz
gentoo-c041c9a6d1228503e15329e7eaffb24dc49c9b5b.tar.bz2
gentoo-c041c9a6d1228503e15329e7eaffb24dc49c9b5b.zip
x11-wm/openbox: Fix IUSE=-xdg w/o python, drop 'static-libs', py39
Closes: https://bugs.gentoo.org/772878 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/openbox-3.6.1-r3.ebuild38
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild38
2 files changed, 42 insertions, 34 deletions
diff --git a/x11-wm/openbox/openbox-3.6.1-r3.ebuild b/x11-wm/openbox/openbox-3.6.1-r3.ebuild
index 0737dc46d366..5a00c19811e0 100644
--- a/x11-wm/openbox/openbox-3.6.1-r3.ebuild
+++ b/x11-wm/openbox/openbox-3.6.1-r3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit autotools python-single-r1
-DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
+DESCRIPTION="Standards compliant, fast, light-weight, extensible window manager"
HOMEPAGE="http://openbox.org/wiki/Main_Page"
if [[ ${PV} == *9999* ]]; then
@@ -21,7 +21,7 @@ SRC_URI+=" branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo
LICENSE="GPL-2"
SLOT="3"
-IUSE="branding debug imlib nls session startup-notification static-libs svg xdg"
+IUSE="branding debug imlib nls session startup-notification svg xdg"
REQUIRED_USE="xdg? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
@@ -51,8 +51,7 @@ RDEPEND="
')
)
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}
x11-base/xorg-proto
"
@@ -62,6 +61,10 @@ PATCHES=(
"${FILESDIR}/${PN}-3.6.1-py3-xdg.patch"
)
+pkg_setup() {
+ use xdg && python-single-r1_pkg_setup
+}
+
src_unpack() {
if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
@@ -71,25 +74,26 @@ src_unpack() {
}
src_prepare() {
- use xdg && python-single-r1_pkg_setup
default
sed -i \
-e "s:-O0 -ggdb ::" \
-e 's/-fno-strict-aliasing//' \
- "${S}"/m4/openbox.m4 || die
+ m4/openbox.m4 || die
eautoreconf
}
src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable static-libs static) \
- $(use_enable nls) \
- $(use_enable imlib imlib2) \
- $(use_enable svg librsvg) \
- $(use_enable startup-notification) \
- $(use_enable session session-management) \
+ local myeconfargs=(
+ --disable-static
--with-x
+ $(use_enable debug)
+ $(use_enable imlib imlib2)
+ $(use_enable nls)
+ $(use_enable session session-management)
+ $(use_enable startup-notification)
+ $(use_enable svg librsvg)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
@@ -106,7 +110,7 @@ src_install() {
"${D}"/etc/xdg/openbox/rc.xml \
|| die "failed to set Surreal Gentoo as the default theme"
fi
- use static-libs || find "${D}" -name '*.la' -delete
+ find "${ED}" -name '*.la' -delete || die
if use xdg ; then
python_fix_shebang "${ED}"/usr/libexec/openbox-xdg-autostart
else
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index 916dd0c62298..f608dddb2d71 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit autotools python-single-r1
-DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
+DESCRIPTION="Standards compliant, fast, light-weight, extensible window manager"
HOMEPAGE="http://openbox.org/wiki/Main_Page"
if [[ ${PV} == *9999* ]]; then
@@ -21,7 +21,7 @@ SRC_URI+=" branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo
LICENSE="GPL-2"
SLOT="3"
-IUSE="branding debug imlib nls session startup-notification static-libs svg xdg"
+IUSE="branding debug imlib nls session startup-notification svg xdg"
REQUIRED_USE="xdg? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
@@ -51,8 +51,7 @@ RDEPEND="
')
)
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}
x11-base/xorg-proto
"
@@ -62,6 +61,10 @@ PATCHES=(
"${FILESDIR}/${PN}-3.6.1-py3-xdg.patch"
)
+pkg_setup() {
+ use xdg && python-single-r1_pkg_setup
+}
+
src_unpack() {
if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
@@ -71,25 +74,26 @@ src_unpack() {
}
src_prepare() {
- use xdg && python-single-r1_pkg_setup
default
sed -i \
-e "s:-O0 -ggdb ::" \
-e 's/-fno-strict-aliasing//' \
- "${S}"/m4/openbox.m4 || die
+ m4/openbox.m4 || die
eautoreconf
}
src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable static-libs static) \
- $(use_enable nls) \
- $(use_enable imlib imlib2) \
- $(use_enable svg librsvg) \
- $(use_enable startup-notification) \
- $(use_enable session session-management) \
+ local myeconfargs=(
+ --disable-static
--with-x
+ $(use_enable debug)
+ $(use_enable imlib imlib2)
+ $(use_enable nls)
+ $(use_enable session session-management)
+ $(use_enable startup-notification)
+ $(use_enable svg librsvg)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
@@ -106,7 +110,7 @@ src_install() {
"${D}"/etc/xdg/openbox/rc.xml \
|| die "failed to set Surreal Gentoo as the default theme"
fi
- use static-libs || find "${D}" -name '*.la' -delete
+ find "${ED}" -name '*.la' -delete || die
if use xdg ; then
python_fix_shebang "${ED}"/usr/libexec/openbox-xdg-autostart
else