summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 18:40:16 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 18:40:16 +0100
commite2a842800c5113452638727e121b5e4d439290ab (patch)
tree8be4b8a3c87bb087df182fdc9a750a1619bd6eb7 /x11-wm/sithwm
parentx11-wm/echinus: Port to EAPI 7 (diff)
downloadgentoo-e2a842800c5113452638727e121b5e4d439290ab.tar.gz
gentoo-e2a842800c5113452638727e121b5e4d439290ab.tar.bz2
gentoo-e2a842800c5113452638727e121b5e4d439290ab.zip
x11-wm/sithwm: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-wm/sithwm')
-rw-r--r--x11-wm/sithwm/files/sithwm-1.2.3-install.patch11
-rw-r--r--x11-wm/sithwm/sithwm-1.2.3.ebuild16
2 files changed, 18 insertions, 9 deletions
diff --git a/x11-wm/sithwm/files/sithwm-1.2.3-install.patch b/x11-wm/sithwm/files/sithwm-1.2.3-install.patch
new file mode 100644
index 000000000000..58d557c4360a
--- /dev/null
+++ b/x11-wm/sithwm/files/sithwm-1.2.3-install.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -64,7 +64,7 @@
+ install: sithwm
+ if [ -f sithwm.exe ]; then mv sithwm.exe sithwm; fi
+ mkdir -p $(prefix)/bin $(prefix)/share/man/man1 $(confdir)
+- install -s sithwm $(prefix)/bin
++ install sithwm $(prefix)/bin
+ install sithwm.1 $(prefix)/share/man/man1
+ install default.sithwmrc $(confdir)
+ @if test -x /usr/bin/update-menus; then \
diff --git a/x11-wm/sithwm/sithwm-1.2.3.ebuild b/x11-wm/sithwm/sithwm-1.2.3.ebuild
index 74bd02edc37a..caa3c5dbdb8c 100644
--- a/x11-wm/sithwm/sithwm-1.2.3.ebuild
+++ b/x11-wm/sithwm/sithwm-1.2.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Minimalist Window Manager for X"
HOMEPAGE="http://sithwm.darkside.no/"
@@ -12,16 +12,14 @@ SRC_URI="http://sithwm.darkside.no/sn/sithwm-1.2.3.tgz"
LICENSE="GPL-2+ MIT 9wm"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-warnings.patch
- sed -e 's|install -s|install|g' \
- -i Makefile || die
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-warnings.patch
+ "${FILESDIR}"/${P}-install.patch
+)
src_compile() {
emake CC="$(tc-getCC)"