summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-05-05 15:11:29 +0200
committerMichael Weber <xmw@gentoo.org>2016-05-05 15:13:42 +0200
commit33e3b1279edee0329f02c129165b278c22918433 (patch)
treed60864fff7055c3dda2b2faa0da6646833b9cc64 /x11-wm/spectrwm
parentdev-libs/unittest++: bump to 1.6.1 (diff)
downloadgentoo-33e3b1279edee0329f02c129165b278c22918433.tar.gz
gentoo-33e3b1279edee0329f02c129165b278c22918433.tar.bz2
gentoo-33e3b1279edee0329f02c129165b278c22918433.zip
x11-wm/spectrwm: Fix library path (bug 580452, thanks sdoubleyou).
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-wm/spectrwm')
-rw-r--r--x11-wm/spectrwm/spectrwm-2.7.2-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/spectrwm/spectrwm-2.7.2-r1.ebuild b/x11-wm/spectrwm/spectrwm-2.7.2-r1.ebuild
new file mode 100644
index 000000000000..f07f74fa295f
--- /dev/null
+++ b/x11-wm/spectrwm/spectrwm-2.7.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Small dynamic tiling window manager for X11"
+HOMEPAGE="https://opensource.conformal.com/wiki/spectrwm"
+SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/dmenu"
+DEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-libs/xcb-util
+ !x11-wm/scrotwm"
+
+S=${WORKDIR}/${P}/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.2-Makefile.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake PREFIX="${EROOT}usr" LIBDIR="${EROOT}usr/$(get_libdir)"
+}
+
+src_install() {
+ emake PREFIX="${EROOT}usr" DESTDIR="${D}" install
+
+ cd "${WORKDIR}"/${P} || die
+
+ insinto /etc
+ doins ${PN}.conf
+ dodoc ${PN}_*.conf {initscreen,screenshot}.sh
+
+ make_session_desktop ${PN} ${PN}
+
+ elog "Example keyboard config and helpful scripts can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}"
+}