summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-14 22:46:36 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-14 22:50:18 -0600
commitd9a63fb4ac19302272b3a4d6208520917c250ca5 (patch)
treeaa9ade1f5603bb3213063be15bc84b9faa81511a /x11-wm/subtle/subtle-0.11.3244.ebuild
parentsys-fs/fuse: add missing conditional test RESTRICT (diff)
downloadgentoo-d9a63fb4ac19302272b3a4d6208520917c250ca5.tar.gz
gentoo-d9a63fb4ac19302272b3a4d6208520917c250ca5.tar.bz2
gentoo-d9a63fb4ac19302272b3a4d6208520917c250ca5.zip
x11-wm/subtle: update supported ruby versions and bump to EAPI 7
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'x11-wm/subtle/subtle-0.11.3244.ebuild')
-rw-r--r--x11-wm/subtle/subtle-0.11.3244.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-wm/subtle/subtle-0.11.3244.ebuild b/x11-wm/subtle/subtle-0.11.3244.ebuild
index 6417ae23f9b2..e0a5b55666b7 100644
--- a/x11-wm/subtle/subtle-0.11.3244.ebuild
+++ b/x11-wm/subtle/subtle-0.11.3244.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-USE_RUBY="ruby22 ruby23 ruby24"
+EAPI="7"
+USE_RUBY="ruby24 ruby25 ruby26"
inherit ruby-ng toolchain-funcs
@@ -28,8 +28,8 @@ RDEPEND="x11-libs/libX11
xpm? ( x11-libs/libXpm )
xtest? ( x11-libs/libXtst )
xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
ruby_add_rdepend "dev-ruby/archive-tar-minitar"
ruby_add_bdepend "dev-ruby/rake doc? ( dev-ruby/rdoc )"
@@ -79,7 +79,7 @@ all_ruby_install() {
dodoc AUTHORS NEWS
- use doc && dohtml -r html/*
+ use doc && dodoc -r html
}
pkg_postinst() {