summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:15:21 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:33 +0000
commitacc2679259137e745ac81da9ed21f0486496fa85 (patch)
tree411197f9fe80c287ec0464f594687d112f731618 /x11-wm/windowlab/windowlab-1.40-r1.ebuild
parentx11-terms/xterm: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-acc2679259137e745ac81da9ed21f0486496fa85.tar.gz
gentoo-acc2679259137e745ac81da9ed21f0486496fa85.tar.bz2
gentoo-acc2679259137e745ac81da9ed21f0486496fa85.zip
x11-wm/windowlab: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm/windowlab/windowlab-1.40-r1.ebuild')
-rw-r--r--x11-wm/windowlab/windowlab-1.40-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-wm/windowlab/windowlab-1.40-r1.ebuild b/x11-wm/windowlab/windowlab-1.40-r1.ebuild
index 9d51612cab05..b8af8cf8cf79 100644
--- a/x11-wm/windowlab/windowlab-1.40-r1.ebuild
+++ b/x11-wm/windowlab/windowlab-1.40-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,8 +26,8 @@ PATCHES=( "${FILESDIR}/${PN}-1.34-fixed-font.patch"
pkg_setup() {
if use truetype ; then
export DEFINES=-DXFT
- export EXTRA_INC=$(pkg-config --cflags xft)
- export EXTRA_LIBS=$(pkg-config --libs xft)
+ export EXTRA_INC=$($(tc-getPKG_CONFIG) --cflags xft)
+ export EXTRA_LIBS=$($(tc-getPKG_CONFIG) --libs xft)
fi
tc-export CC
}