summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2016-03-03 11:33:56 -0800
committerDaniel Campbell <zlg@gentoo.org>2016-03-03 11:36:56 -0800
commit0fe26d576d2b2093942ce6cc4a1b065c24847876 (patch)
tree9e738d5e8f2eb8265142e19a82562489239e601a /x11-wm
parentdev-libs/libinput: Fix typo in libwacom dependency (diff)
downloadgentoo-0fe26d576d2b2093942ce6cc4a1b065c24847876.tar.gz
gentoo-0fe26d576d2b2093942ce6cc4a1b065c24847876.tar.bz2
gentoo-0fe26d576d2b2093942ce6cc4a1b065c24847876.zip
x11-wm/page: Revbump, fix file collision
Gentoo-Bug: 574074 Gentoo-Bug-URL: https://bugs.gentoo.org/574074 Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/page/page-1.9.6-r5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-wm/page/page-1.9.6-r5.ebuild b/x11-wm/page/page-1.9.6-r5.ebuild
new file mode 100644
index 000000000000..04c3b753978b
--- /dev/null
+++ b/x11-wm/page/page-1.9.6-r5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A mouse friendly tiling window manager"
+HOMEPAGE="http://www.hzog.net/index.php/Main_Page"
+SRC_URI="http://www.hzog.net/pub/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-proto/xcb-proto
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-proto/damageproto
+ x11-proto/randrproto
+ x11-libs/libXrandr
+ x11-proto/xproto
+ x11-proto/fixesproto
+ x11-proto/compositeproto
+ x11-libs/libXcomposite
+ x11-proto/renderproto
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-proto/xextproto
+ x11-libs/cairo[xcb]
+ x11-libs/pango
+ dev-libs/glib:2"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+ # Solves file collision with dev-tcltk/tcllib, bug #574074
+ ebegin "Changing references from 'page' to 'pagewm'"
+ mv "${D}"usr/bin/page "${D}"usr/bin/pagewm || die "Could not rename binary!"
+ sed -i -e "s:/usr/bin/page:/usr/bin/pagewm:" "${D}"usr/share/applications/page.desktop || die "Could not change .desktop file!"
+ eend
+}
+
+pkg_postinst() {
+ elog "page can now be launched using "pagewm". For information on why, please see"
+ elog "https://bugs.gentoo.org/574074."
+}