summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-17 21:08:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-17 21:09:32 +0200
commit5810217300f5133478f150dc24d78f53031400d9 (patch)
treec2e0ce5e0ee2d361fd6badee41a2abc8a546b43a /x11-wm
parentnet-wireless/unifi: bump to 5.13.32, drop old (diff)
downloadgentoo-5810217300f5133478f150dc24d78f53031400d9.tar.gz
gentoo-5810217300f5133478f150dc24d78f53031400d9.tar.bz2
gentoo-5810217300f5133478f150dc24d78f53031400d9.zip
x11-wm/page: add back an old version and update HOMEPAGE.
Set HOMEPAGE to Github. Bug: https://bugs.gentoo.org/727918 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/page/Manifest1
-rw-r--r--x11-wm/page/page-1.9.8.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-wm/page/Manifest b/x11-wm/page/Manifest
index d582910bde41..78488740ed59 100644
--- a/x11-wm/page/Manifest
+++ b/x11-wm/page/Manifest
@@ -1 +1,2 @@
+DIST page-1.9.8.tar.gz 162352 BLAKE2B acde0feb62d58f66708ec09545137978540fb8c5fab651961b6e87d7c9d7be3170b8e2171c80ec553a9059ae2c23869759f37953da783be3a8fb3ea471e8b15b SHA512 758b1efbecb6d0a3d6ea0f7261b1c55db0927aa46d871f1a30b77e5aa7b9819ae74ca6fb821692656f2150da758793ba5653bdd94ab92ba2b79b39e0d4a4882e
DIST page-1.9.9-r1.tar.gz 1009216 BLAKE2B 8248705f9e5eceaeea37889a9859249d9eb236f215da804f5edad3c36007179f63f132c161c1e4a6a97df6240f87799242140c97877775ae00f2e86dd7eed69d SHA512 9e7594590b1fdeadcf59d715d30727bee9f640903a34cadd8c0d92b3e94059c183d931a7d8e96763adb74f59a94acb03f7bfbbd4f1f8b57371fe886e6a227012
diff --git a/x11-wm/page/page-1.9.8.ebuild b/x11-wm/page/page-1.9.8.ebuild
new file mode 100644
index 000000000000..8fcd55186a3b
--- /dev/null
+++ b/x11-wm/page/page-1.9.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A mouse friendly tiling window manager"
+HOMEPAGE="https://github.com/gschwind/page"
+SRC_URI="https://github.com/gschwind/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11[xkb]
+ >=x11-libs/xcb-util-0.4.0
+ >=x11-libs/libXfixes-5.0.3
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXrandr-1.5.1
+ >=x11-libs/libXcomposite-0.4.4-r1
+ >=x11-libs/libXrender-0.9.10
+ >=x11-libs/libXext-1.3.3
+ >=x11-libs/cairo-1.14.6[X,xcb(+)]
+ >=x11-libs/pango-1.40.5
+ >=dev-libs/glib-2.50.3-r1:2"
+
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.12-r2
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # Solves file collision with dev-tcltk/tcllib, bug #574074
+ ebegin "Changing references from 'page' to 'pagewm'"
+ mv "${D}"usr/bin/page "${D}"usr/bin/pagewm || die "Could not rename binary!"
+ sed -i -e "s:/usr/bin/page:/usr/bin/pagewm:" "${D}"usr/share/applications/page.desktop || die "Could not change .desktop file!"
+ eend
+}
+
+pkg_postinst() {
+ elog "page can now be launched using \"pagewm\". To find out more about this functionality,"
+ elog "see the following bug report: https://bugs.gentoo.org/574074."
+}