summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-09-12 16:31:22 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-09-12 16:32:37 +0300
commit78bf10fcee88d2aa01144b3489f3a95ec18b44ea (patch)
tree8b44b21ade6a5fae8349d85ad694047d95f9e727 /x11-wm
parentdev-lang/xsb: stable on amd64 + x86. Closes 741688 (diff)
downloadgentoo-78bf10fcee88d2aa01144b3489f3a95ec18b44ea.tar.gz
gentoo-78bf10fcee88d2aa01144b3489f3a95ec18b44ea.tar.bz2
gentoo-78bf10fcee88d2aa01144b3489f3a95ec18b44ea.zip
x11-wm/qtile: Version bump (v0.16.1)
Closes: https://bugs.gentoo.org/734970 Closes: https://bugs.gentoo.org/734972 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/qtile-0.16.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 954a439a8bfb..c752cba5191f 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1,2 +1,3 @@
DIST qtile-0.15.1.tar.gz 522233 BLAKE2B cb5c35ab6b2e22d36c2ef69a3d6367033440a25a1c06dad5c4d455b67aa1ddf2c639451e051abcd40b5a76e93250a54271408bbe09008b44a5ebf0a520b3eb2e SHA512 57dfeeea212346c14b922303b5d2fd950292383a1da3be6bf5ca0880bedaa3adb7ffc121df617cf763fcd1208c44e34a7ba128a1f2a6e8d3042dd6906ece7e20
DIST qtile-0.16.0.tar.gz 543646 BLAKE2B d0d2ae1bf44e08c7a40601fee0643fb387807546ebee5ab6f6756d7651be22fff75034227226fe978042b33594158b5493ca6203ecab92434418219a423a5817 SHA512 c8f712fcf48f166be0782560541d02959809f5c7d6ee209e3bf0b12325309521be79eab81e4f17f5111fb9426601ac5445db0bb3dc8330e9b426fa1031e95065
+DIST qtile-0.16.1.tar.gz 324668 BLAKE2B 1f75f5dbcab6180dcf778e28108e70b6dd01105fa275aadf4a53d96ab84f3b759cb8553bcf3de2011b0990d61adc9269663afa32b83d1aa9c052b00ef9e89358 SHA512 aea42f7f6799a88b586167a57f5b5ab6f1c5bb663dec352d15eb47ce0d37fb23c31d1631cab8178c71be5ae714ec12c35a350377383dba1749a98cd45c22515b
diff --git a/x11-wm/qtile/qtile-0.16.1.ebuild b/x11-wm/qtile/qtile-0.16.1.ebuild
new file mode 100644
index 000000000000..8b592a3ecadc
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.16.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+
+# requires internet and specific
+# pulseaudio settings
+
+RDEPEND="
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/pango
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.8.1[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+"
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+} \ No newline at end of file