summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-21 21:13:41 +0000
committerSam James <sam@gentoo.org>2021-01-21 21:13:41 +0000
commit7ffeb29f4b379820371400733aba4005cfb91846 (patch)
tree248d87f368ffccab790e0a76375e5e3752c2b018 /x11-wm
parentdev-libs/pugixml: Stabilize 1.11.4 ppc64, #766021 (diff)
downloadgentoo-7ffeb29f4b379820371400733aba4005cfb91846.tar.gz
gentoo-7ffeb29f4b379820371400733aba4005cfb91846.tar.bz2
gentoo-7ffeb29f4b379820371400733aba4005cfb91846.zip
x11-wm/awesome: Revert "Remove old"
This reverts commit 71f9ebdc417560bcb3322f029ef3fff48389eadb. This was meant to drop 4.2.x. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/awesome-4.3-r2.ebuild139
-rw-r--r--x11-wm/awesome/files/awesome-3.5.5-cflag-cleanup.patch12
-rw-r--r--x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch46
-rw-r--r--x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch51
-rw-r--r--x11-wm/awesome/files/awesome-3.5_rc1-convert-path.patch12
5 files changed, 260 insertions, 0 deletions
diff --git a/x11-wm/awesome/awesome-4.3-r2.ebuild b/x11-wm/awesome/awesome-4.3-r2.ebuild
new file mode 100644
index 000000000000..c402663215fd
--- /dev/null
+++ b/x11-wm/awesome/awesome-4.3-r2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop pax-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/awesomeWM/${PN}.git"
+else
+ SRC_URI="https://github.com/awesomeWM/awesome-releases/raw/master/${P}.tar.xz"
+ KEYWORDS="amd64 arm ppc ppc64 x86"
+fi
+
+DESCRIPTION="A dynamic floating and tiling window manager"
+HOMEPAGE="https://awesomewm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dbus doc gnome luajit test"
+RESTRICT="test" # https://bugs.gentoo.org/654084
+
+RDEPEND="
+ dev-lang/lua:0
+ dev-libs/glib:2
+ dev-libs/libxdg-basedir
+ dev-lua/lgi
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxcb[xkb]
+ x11-libs/pango[introspection]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-libs/libXcursor
+ x11-libs/libxkbcommon[X]
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
+DEPEND="${RDEPEND}
+ x11-base/xcb-proto
+ x11-base/xorg-proto
+ test? (
+ x11-base/xorg-server[xvfb]
+ dev-lua/busted
+ dev-lua/luacheck
+ )
+"
+BDEPEND="
+ app-text/asciidoc
+ media-gfx/imagemagick[png]
+ virtual/pkgconfig
+ doc? ( dev-lua/ldoc )
+ test? ( app-shells/zsh )"
+
+# Skip installation of README.md by einstalldocs, which leads to broken symlink
+DOCS=()
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0-convert-path.patch # bug #408025
+ "${FILESDIR}"/${PN}-xsession.patch # bug #408025
+ "${FILESDIR}"/${PN}-4.0-cflag-cleanup.patch # bug #509658
+ "${FILESDIR}"/${P}-fno-common.patch # bug #707262
+)
+
+src_configure() {
+ # Compression of manpages is handled by portage
+ local mycmakeargs=(
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ -DCOMPRESS_MANPAGES=OFF
+ -DWITH_DBUS=$(usex dbus)
+ -DGENERATE_DOC=$(usex doc)
+ -DAWESOME_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ if use luajit; then
+ mycmakeargs+=("-DLUA_INCLUDE_DIR=${EPREFIX}/usr/include/luajit-2.0")
+ mycmakeargs+=("-DLUA_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libluajit-5.1.so")
+ fi
+ cmake_src_configure
+}
+
+src_test() {
+ # awesome's test suite starts Xvfb by itself, no need for virtualx eclass
+ HEADLESS=1 cmake_build check -j1
+}
+
+src_install() {
+ cmake_src_install
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
+
+ pax-mark m "${ED}"/usr/bin/awesome
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ # GNOME-based awesome
+ if use gnome; then
+ # GNOME session
+ insinto /usr/share/gnome-session/sessions
+ newins "${FILESDIR}"/${PN}-gnome-3.session ${PN}-gnome.session
+
+ # Application launcher
+ domenu "${FILESDIR}"/${PN}-gnome.desktop
+
+ # X Session
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}-gnome-xsession.desktop
+ fi
+
+ # This directory contains SVG images which we don't want to compress
+ use doc && docompress -x /usr/share/doc/${PF}/doc
+}
+
+pkg_postinst() {
+ # bug #447308
+ if use gnome; then
+ elog "You have enabled the gnome USE flag."
+ elog "Please note that quitting awesome won't kill your gnome session."
+ elog "To really quit the session, you should bind your quit key"
+ elog "to the following command:"
+ elog " gnome-session-quit --logout"
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=447308"
+ fi
+
+ # bug #440724
+ elog "If you are having issues with Java application windows being"
+ elog "completely blank, try installing"
+ elog " x11-misc/wmname"
+ elog "and setting the WM name to LG3D."
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=440724"
+}
diff --git a/x11-wm/awesome/files/awesome-3.5.5-cflag-cleanup.patch b/x11-wm/awesome/files/awesome-3.5.5-cflag-cleanup.patch
new file mode 100644
index 000000000000..3cfeaba2df36
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5.5-cflag-cleanup.patch
@@ -0,0 +1,12 @@
+diff -u awesome-3.5.5/awesomeConfig.cmake awesome-3.5.5.new/awesomeConfig.cmake
+--- awesome-3.5.5/awesomeConfig.cmake 2014-08-24 23:28:04.178646000 -0400
++++ awesome-3.5.5.new/awesomeConfig.cmake 2014-08-24 23:28:44.204646000 -0400
+@@ -16,7 +16,7 @@
+ option(GENERATE_DOC "generate API documentation" ON)
+
+ # {{{ CFLAGS
+-add_definitions(-O1 -std=gnu99 -ggdb3 -rdynamic -fno-strict-aliasing -Wall -Wextra
++add_definitions(-std=gnu99 -fno-strict-aliasing -Wall -Wextra
+ -Wchar-subscripts -Wundef -Wshadow -Wcast-align -Wwrite-strings
+ -Wsign-compare -Wunused -Wno-unused-parameter -Wuninitialized -Winit-self
+ -Wpointer-arith -Wformat-nonliteral
diff --git a/x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch b/x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch
new file mode 100644
index 000000000000..588f9ab9ec52
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5.5-util.lua-xdg-icons-fix.patch
@@ -0,0 +1,46 @@
+From: Uli Schlachter <psychon@znc.in>
+Date: Sat, 12 Apr 2014 14:15:11 +0000 (+0200)
+Subject: Merge git://github.com/Teknocrat/awesome
+X-Git-Url: http://git.naquadah.org/?p=awesome.git;a=commitdiff_plain;h=d76d3e0b6a00b8b289b3801ba197e0dae732a92d;hp=1090719d677c86e90a1394a34f0effb418728493
+
+Merge git://github.com/Teknocrat/awesome
+---
+
+diff --git a/lib/awful/util.lua.in b/lib/awful/util.lua.in
+index 1d35f2f..123c4a6 100644
+--- a/lib/awful/util.lua.in
++++ b/lib/awful/util.lua.in
+@@ -185,21 +185,24 @@ end
+ -- of the dirs are searched first
+ function util.geticonpath(iconname, exts, dirs, size)
+ exts = exts or { 'png', 'gif' }
+- dirs = dirs or { '/usr/share/pixmaps/' }
++ dirs = dirs or { '/usr/share/pixmaps/', '/usr/share/icons/hicolor/' }
++ icontypes = { 'apps', 'actions', 'categories', 'emblems',
++ 'mimetypes', 'status', 'devices', 'extras', 'places', 'stock' }
+ for _, d in pairs(dirs) do
++ local icon
+ for _, e in pairs(exts) do
+- local icon
+- if size then
+- icon = string.format("%s%ux%u/%s.%s",
+- d, size, size, iconname, e)
+- if util.file_readable(icon) then
+- return icon
+- end
+- end
+ icon = d .. iconname .. '.' .. e
+ if util.file_readable(icon) then
+ return icon
+ end
++ if size then
++ for _, t in pairs(icontypes) do
++ icon = string.format("%s%ux%u/%s/%s.%s", d, size, size, t, iconname, e)
++ if util.file_readable(icon) then
++ return icon
++ end
++ end
++ end
+ end
+ end
+ end
diff --git a/x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch b/x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch
new file mode 100644
index 000000000000..67f0d9810f44
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch
@@ -0,0 +1,51 @@
+diff -Nuar awesome-3.5.9.orig/build-utils/lgi-check.sh awesome-3.5.9/build-utils/lgi-check.sh
+--- awesome-3.5.9.orig/build-utils/lgi-check.sh 2016-03-06 14:05:54.000000000 +0000
++++ awesome-3.5.9/build-utils/lgi-check.sh 2019-01-23 21:36:35.973967623 +0000
+@@ -1,5 +1,7 @@
+ #!/bin/sh
+
++LUA=${LUA:=lua}
++
+ die()
+ {
+ exec >&2
+@@ -22,11 +24,11 @@
+ }
+
+ # Check if we have lgi
+-lua -e 'require("lgi")' || die
++$LUA -e 'require("lgi")' || die
+
+ # Check the version number
+ # Keep this in sync with lib/gears/surface.lua.in!
+-lua -e 'if tonumber(string.match(require("lgi.version"), "(%d%.%d)")) < 0.7 then error("lgi too old, need at least version 0.7.0") end' || die
++$LUA -e 'if tonumber(string.match(require("lgi.version"), "(%d%.%d)")) < 0.7 then error("lgi too old, need at least version 0.7.0") end' || die
+
+ # Check for the needed gi files
+-lua -e 'l = require("lgi") assert(l.cairo, l.Pango, l.PangoCairo)' || die
++$LUA -e 'l = require("lgi") assert(l.cairo, l.Pango, l.PangoCairo)' || die
+diff -Nuar awesome-3.5.9.orig/awesomeConfig.cmake awesome-3.5.9/awesomeConfig.cmake
+--- awesome-3.5.9.orig/awesomeConfig.cmake 2019-01-23 22:01:17.364046606 +0000
++++ awesome-3.5.9/awesomeConfig.cmake 2019-01-23 21:50:30.152919084 +0000
+@@ -66,6 +66,7 @@
+ include(FindPkgConfig)
+ # lua 5.1
+ include(FindLua51)
++set(ENV{LUA} "${LUA_EXECUTABLE}")
+ # }}}
+
+ # {{{ Check if documentation can be build
+diff -Nuar awesome-3.5.9.orig/CMakeLists.txt awesome-3.5.9/CMakeLists.txt
+--- awesome-3.5.9.orig/CMakeLists.txt 2016-03-06 14:05:54.000000000 +0000
++++ awesome-3.5.9/CMakeLists.txt 2019-01-23 22:00:08.715111414 +0000
+@@ -105,7 +105,9 @@
+
+ # check for lgi and the needed gobject introspection files
+ add_custom_target(lgi-check ALL
+- COMMAND ${SOURCE_DIR}/build-utils/lgi-check.sh)
++ COMMAND ${CMAKE_COMMAND} -E env LUA=${LUA_EXECUTABLE} ${SOURCE_DIR}/build-utils/lgi-check.sh
++ COMMENT "Verifying LGI module")
++# VERBATIM)
+
+ # atoms
+ file(MAKE_DIRECTORY ${BUILD_DIR}/common)
diff --git a/x11-wm/awesome/files/awesome-3.5_rc1-convert-path.patch b/x11-wm/awesome/files/awesome-3.5_rc1-convert-path.patch
new file mode 100644
index 000000000000..e6c37b0f9c76
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5_rc1-convert-path.patch
@@ -0,0 +1,12 @@
+diff -Nuar --exclude '*.orig' awesome-3.5-rc1.orig/awesomeConfig.cmake awesome-3.5-rc1/awesomeConfig.cmake
+--- awesome-3.5-rc1.orig/awesomeConfig.cmake 2012-11-24 13:51:33.000000000 +0000
++++ awesome-3.5-rc1/awesomeConfig.cmake 2012-11-24 20:42:23.743412441 +0000
+@@ -56,7 +56,7 @@
+ a_find_program(LUA_EXECUTABLE lua FALSE)
+ a_find_program(LDOC_EXECUTABLE ldoc.lua FALSE)
+ # theme graphics
+-a_find_program(CONVERT_EXECUTABLE convert TRUE)
++a_find_program(CONVERT_EXECUTABLE bin/convert TRUE)
+ # doxygen
+ include(FindDoxygen)
+ # pkg-config