summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-12-06 12:10:18 +0100
committerJeroen Roovers <jer@gentoo.org>2019-12-06 12:10:53 +0100
commit90581d54dac720e4e093deccaa4da3ed2bf2c074 (patch)
tree2924ea1df503adbe0b90ea2194c480075fb91894 /x11-wm
parentpackage.mask: unmask media-sound/abcde, no longer needs py2 (diff)
downloadgentoo-90581d54dac720e4e093deccaa4da3ed2bf2c074.tar.gz
gentoo-90581d54dac720e4e093deccaa4da3ed2bf2c074.tar.bz2
gentoo-90581d54dac720e4e093deccaa4da3ed2bf2c074.zip
x11-wm/herbstluftwm: Export PKG_CONFIG
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.7.2-r1.ebuild18
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild18
2 files changed, 24 insertions, 12 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.7.2-r1.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.7.2-r1.ebuild
index 9fe9d04ef469..c68ba3acf29a 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-0.7.2-r1.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.7.2-r1.ebuild
@@ -21,17 +21,23 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="examples xinerama zsh-completion"
-DEPEND=">=dev-libs/glib-2.24:2
+DEPEND="
+ >=dev-libs/glib-2.24:2
x11-libs/libX11
x11-libs/libXext
- xinerama? ( x11-libs/libXinerama )"
-RDEPEND="${DEPEND}
+ xinerama? ( x11-libs/libXinerama )
+"
+RDEPEND="
+ ${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )"
-BDEPEND+=" virtual/pkgconfig"
+ zsh-completion? ( app-shells/zsh )
+"
+BDEPEND+="
+ virtual/pkgconfig
+"
src_compile() {
- tc-export CC LD CXX
+ tc-export CC CXX LD PKG_CONFIG
emake LDXX="$(tc-getCXX)" COLOR=0 VERBOSE= \
$(use xinerama || echo XINERAMAFLAGS= XINERAMALIBS= )
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 9fe9d04ef469..c68ba3acf29a 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -21,17 +21,23 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="examples xinerama zsh-completion"
-DEPEND=">=dev-libs/glib-2.24:2
+DEPEND="
+ >=dev-libs/glib-2.24:2
x11-libs/libX11
x11-libs/libXext
- xinerama? ( x11-libs/libXinerama )"
-RDEPEND="${DEPEND}
+ xinerama? ( x11-libs/libXinerama )
+"
+RDEPEND="
+ ${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )"
-BDEPEND+=" virtual/pkgconfig"
+ zsh-completion? ( app-shells/zsh )
+"
+BDEPEND+="
+ virtual/pkgconfig
+"
src_compile() {
- tc-export CC LD CXX
+ tc-export CC CXX LD PKG_CONFIG
emake LDXX="$(tc-getCXX)" COLOR=0 VERBOSE= \
$(use xinerama || echo XINERAMAFLAGS= XINERAMALIBS= )