summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-26 11:32:33 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-26 11:32:33 +0100
commita761d6f08552139aa32011fba0c0daf9fc995e30 (patch)
tree0097a2fda0743daee37ff470e2785765696650ef /x11-wm
parentmedia-libs/icclib: fix build with gcc-10 (diff)
downloadgentoo-a761d6f08552139aa32011fba0c0daf9fc995e30.tar.gz
gentoo-a761d6f08552139aa32011fba0c0daf9fc995e30.tar.bz2
gentoo-a761d6f08552139aa32011fba0c0daf9fc995e30.zip
x11-wm/oroborus: fix build with gcc-10
Closes: https://bugs.gentoo.org/706722 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/oroborus/files/oroborus-2.0.20-fno-common.patch33
-rw-r--r--x11-wm/oroborus/oroborus-2.0.20-r1.ebuild5
2 files changed, 36 insertions, 2 deletions
diff --git a/x11-wm/oroborus/files/oroborus-2.0.20-fno-common.patch b/x11-wm/oroborus/files/oroborus-2.0.20-fno-common.patch
new file mode 100644
index 000000000000..e7a1e2157152
--- /dev/null
+++ b/x11-wm/oroborus/files/oroborus-2.0.20-fno-common.patch
@@ -0,0 +1,33 @@
+--- a/src/hints.c
++++ b/src/hints.c
+@@ -43,7 +43,7 @@ Atom win_hints, win_state, win_client_list, win_layer, win_workspace,
+ win_workspace_count, win_desktop_button_proxy, win_supporting_wm_check,
+ gnome_panel_desktop_area;
+ Atom net_atoms[NET_ATOM_COUNT];
+-Display *dpy;
++extern Display *dpy;
+
+ void
+ initHints (Display * d)
+--- a/src/keyboard.c
++++ b/src/keyboard.c
+@@ -35,6 +35,8 @@
+ #include <stdio.h>
+ #endif
+
++int NumLockMask, CapsLockMask, ScrollLockMask;
++
+ void
+ parseKeyString (Display * dpy, MyKey * key, char *str)
+ {
+--- a/src/keyboard.h
++++ b/src/keyboard.h
+@@ -90,7 +90,7 @@ void grabKey (Display *, MyKey *, Window);
+ void ungrabKeys (Display *, Window);
+ void init_keyboard (Display * dpy);
+
+-int NumLockMask, CapsLockMask, ScrollLockMask;
++extern int NumLockMask, CapsLockMask, ScrollLockMask;
+
+ #endif /* __KEYBOARD_H */
+
diff --git a/x11-wm/oroborus/oroborus-2.0.20-r1.ebuild b/x11-wm/oroborus/oroborus-2.0.20-r1.ebuild
index 071ee8295d30..1c0dec3cece9 100644
--- a/x11-wm/oroborus/oroborus-2.0.20-r1.ebuild
+++ b/x11-wm/oroborus/oroborus-2.0.20-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,6 @@ SRC_URI="mirror://debian/pool/main/o/${PN}/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="
x11-libs/libICE
@@ -21,4 +20,6 @@ RDEPEND="
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
DOCS=( AUTHORS ChangeLog example.${PN}rc README TODO )