summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2016-02-27 18:43:02 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2016-02-27 18:43:41 +0100
commitad92a78ae361eadef516561ac74e8b7afa09beb6 (patch)
treefa8ab2d4eeb181437d565e33a9bcf374197407c3 /x11-wm
parentapp-backup/attic: KEYWORD ~x86 (diff)
downloadgentoo-ad92a78ae361eadef516561ac74e8b7afa09beb6.tar.gz
gentoo-ad92a78ae361eadef516561ac74e8b7afa09beb6.tar.bz2
gentoo-ad92a78ae361eadef516561ac74e8b7afa09beb6.zip
x11-wm/stumpwm: Fix ASDF directory
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.9.ebuild9
-rw-r--r--x11-wm/stumpwm/stumpwm-9999.ebuild2
2 files changed, 8 insertions, 3 deletions
diff --git a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
index d7ebbcf43d99..29808a6e8aa5 100644
--- a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
+++ b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
doc? ( virtual/texi2dvi )"
SITEFILE=70${PN}-gentoo.el
-CONTRIBDIR="${CLSOURCEROOT}/${CLPACKAGE}/contrib"
+CLPKGDIR="${CLSOURCEROOT}/${CLPACKAGE}"
+CONTRIBDIR="${CLPKGDIR}/contrib"
get_lisp() {
local lisp
@@ -55,10 +56,12 @@ do_contrib() {
}
src_prepare() {
+ # Fix ASDF dir
+ sed -i -e "/^STUMPWM_ASDF_DIR/s|\`pwd\`|${CLPKGDIR}|" configure.ac || die
# Upstream didn't change the version before packaging
- sed -i "${S}/${PN}.asd" -e 's/:version "0.9.8"/:version "0.9.9"/' || die
+ sed -i -e 's/:version "0.9.8"/:version "0.9.9"/' "${PN}.asd" || die
# Bug 534592. Does not build with asdf:oos, using require to load the package
- sed -i "${S}/load-${PN}.lisp.in" -e "s/asdf:oos 'asdf:load-op/require/" || die
+ sed -i "load-${PN}.lisp.in" -e "s/asdf:oos 'asdf:load-op/require/" || die
if use contrib ; then
# Fix contrib directory
sed -i -e "s|@CONTRIB_DIR@|@MODULE_DIR@|" make-image.lisp.in || die
diff --git a/x11-wm/stumpwm/stumpwm-9999.ebuild b/x11-wm/stumpwm/stumpwm-9999.ebuild
index 5d604d93448b..cec821a91ec8 100644
--- a/x11-wm/stumpwm/stumpwm-9999.ebuild
+++ b/x11-wm/stumpwm/stumpwm-9999.ebuild
@@ -33,6 +33,8 @@ do_doc() {
}
src_prepare() {
+ # Fix ASDF dir
+ sed -i -e "/^STUMPWM_ASDF_DIR/s|\`pwd\`|${CLPKGDIR}|" configure.ac || die
eautoreconf
}