summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-01 23:33:53 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-01 23:33:53 -0600
commitcdbe01c0bedc0888cbbeb462231e311262c70a34 (patch)
tree9f97f06e82bfc6e95fe8b7ab2350a782e48624c4 /x11-wm
parentmedia-sound/abcmidi: remove old (diff)
downloadgentoo-cdbe01c0bedc0888cbbeb462231e311262c70a34.tar.gz
gentoo-cdbe01c0bedc0888cbbeb462231e311262c70a34.tar.bz2
gentoo-cdbe01c0bedc0888cbbeb462231e311262c70a34.zip
x11-wm/bspwm: fix docs install
Closes: https://bugs.gentoo.org/689052 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/bspwm/bspwm-0.9.7-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-wm/bspwm/bspwm-0.9.7-r1.ebuild b/x11-wm/bspwm/bspwm-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..484d61f26f28
--- /dev/null
+++ b/x11-wm/bspwm/bspwm-0.9.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Tiling window manager based on binary space partitioning"
+HOMEPAGE="https://github.com/baskerville/bspwm/"
+SRC_URI="https://github.com/baskerville/bspwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+"
+RDEPEND="${DEPEND}
+ x11-misc/sxhkd
+"
+
+src_compile() {
+ emake PREFIX=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCPREFIX="/usr/share/doc/${PF}" install
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ insinto /usr/share/xsessions
+ doins contrib/freedesktop/bspwm.desktop
+
+ insinto /etc/xdg/sxhkd
+ doins examples/sxhkdrc
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}