summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-23 10:06:10 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-23 10:16:23 +0100
commitd94965fb1e536dc6203b3cb5e2ec7eee91da6b98 (patch)
tree5ba76a3ba3ca14d4739fcc460582474416c63629 /x11-wm
parenttoolchain-funcs.eclass: new function tc-ld-force-bfd() (diff)
downloadgentoo-d94965fb1e536dc6203b3cb5e2ec7eee91da6b98.tar.gz
gentoo-d94965fb1e536dc6203b3cb5e2ec7eee91da6b98.tar.bz2
gentoo-d94965fb1e536dc6203b3cb5e2ec7eee91da6b98.zip
x11-wm/windowmaker: fix cross-compiling, NLS, static libs
Thanks David Michael <fedora.dm0@gmail.com> for the changes Closes: https://bugs.gentoo.org/746017 Closes: https://bugs.gentoo.org/763558 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild118
-rw-r--r--x11-wm/windowmaker/windowmaker-9999.ebuild66
2 files changed, 156 insertions, 28 deletions
diff --git a/x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild b/x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild
new file mode 100644
index 000000000000..169193220615
--- /dev/null
+++ b/x11-wm/windowmaker/windowmaker-0.95.9-r2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop eutils
+
+DESCRIPTION="The fast and light GNUstep window manager"
+HOMEPAGE="https://www.windowmaker.org/"
+SRC_URI="https://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
+ https://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gif imagemagick jpeg modelock nls png tiff webp xinerama +xpm xrandr"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="media-libs/fontconfig
+ >=x11-libs/libXft-2.1.0
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXv
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ imagemagick? ( >=media-gfx/imagemagick-7:0= )
+ jpeg? ( virtual/jpeg:0= )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0 )
+ webp? ( media-libs/libwebp )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
+
+S=${WORKDIR}/${P/windowm/WindowM}
+
+DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL-WMAKER FAQ
+ NEWS README README.definable-cursor README.i18n TODO )
+PATCHES=( "${FILESDIR}"/${PN}-0.95.8-configure_default_search_paths.patch )
+
+src_prepare() {
+ # Fix some paths
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s|/usr/local/GNUstep/Applications/WPrefs.app|${EPREFIX}/usr/bin/|g;" "$file" || die
+ sed -i -e "s|/usr/local/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
+ sed -i -e "s|/opt/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
+ fi
+ done
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local -a myeconfargs=(
+ # image format types
+ $(use_enable gif)
+ $(use_enable imagemagick magick)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable tiff)
+ $(use_enable webp)
+ $(use_enable xpm)
+
+ # optional X capabilities
+ $(use_enable modelock)
+ $(use_enable xinerama)
+ $(use_enable xrandr randr)
+ )
+
+ # NLS depends on whether LINGUAS is empty
+ if use nls; then
+ myeconfargs+=( LINGUAS="${LINGUAS:-$(cd po; x=(*.po); echo ${x[*]%.po})}" )
+ else
+ myeconfargs+=( LINGUAS= )
+ fi
+
+ econf \
+ --localedir="${EPREFIX}"/usr/share/locale \
+ --sysconfdir="${EPREFIX}"/etc/X11 \
+ --disable-static \
+ --enable-usermenu \
+ --with-{incs,libs}-from= \
+ --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
+ --with-x \
+ "${myeconfargs[@]}"
+
+ pushd ../WindowMaker-extra-0.1 &>/dev/null || die
+ econf
+}
+
+src_compile() {
+ emake
+
+ # WindowMaker Extra Package (themes and icons)
+ emake -C ../WindowMaker-extra-0.1
+}
+
+src_install() {
+ default
+
+ # WindowMaker Extra
+ emake -C ../WindowMaker-extra-0.1 DESTDIR="${D}" install
+ newdoc ../WindowMaker-extra-0.1/README README.extra
+
+ # create wmaker session shell script
+ echo "#!/usr/bin/env bash" > wmaker
+ echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/wmaker.desktop
+ make_desktop_entry /usr/bin/wmaker
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/x11-wm/windowmaker/windowmaker-9999.ebuild b/x11-wm/windowmaker/windowmaker-9999.ebuild
index 9fabfa3d5f0b..5cc89fa45b5b 100644
--- a/x11-wm/windowmaker/windowmaker-9999.ebuild
+++ b/x11-wm/windowmaker/windowmaker-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop eutils git-r3
+inherit autotools desktop git-r3
DESCRIPTION="The fast and light GNUstep window manager"
HOMEPAGE="https://www.windowmaker.org/"
@@ -24,15 +24,16 @@ DEPEND="media-libs/fontconfig
gif? ( >=media-libs/giflib-4.1.0-r3 )
imagemagick? ( >=media-gfx/imagemagick-7:0= )
jpeg? ( virtual/jpeg:0= )
+ nls? ( virtual/libintl )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0 )
webp? ( media-libs/libwebp )
xinerama? ( x11-libs/libXinerama )
xrandr? ( x11-libs/libXrandr )"
-RDEPEND="${DEPEND}
- nls? ( >=sys-devel/gettext-0.10.39 )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
-DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL INSTALL-WMAKER FAQ
+DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL-WMAKER FAQ
NEWS README README.definable-cursor README.i18n TODO )
src_unpack() {
@@ -49,38 +50,48 @@ src_prepare() {
sed -i -e "s|/usr/local/GNUstep/Applications/WPrefs.app|${EPREFIX}/usr/bin/|g;" "$file" || die
sed -i -e "s|/usr/local/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
sed -i -e "s|/opt/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
- fi;
- done;
+ fi
+ done
default
eautoreconf
}
src_configure() {
- local myconf
-
- # image format types
- myconf="$(use_enable imagemagick magick) $(use_enable jpeg) $(use_enable gif) $(use_enable png) $(use_enable tiff) $(use_enable webp) $(use_enable xpm)"
-
- # non required X capabilities
- myconf="${myconf} $(use_enable modelock) $(use_enable xrandr randr) $(use_enable xinerama)"
-
+ local -a myeconfargs=(
+ # image format types
+ $(use_enable gif)
+ $(use_enable imagemagick magick)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable tiff)
+ $(use_enable webp)
+ $(use_enable xpm)
+
+ # optional X capabilities
+ $(use_enable modelock)
+ $(use_enable xinerama)
+ $(use_enable xrandr randr)
+ )
+
+ # NLS depends on whether LINGUAS is empty
if use nls; then
- [[ -z $LINGUAS ]] && export LINGUAS="$(ls po/*.po | sed 's:po/\(.*\)\.po$:\1:' | xargs)"
+ myeconfargs+=( LINGUAS="${LINGUAS:-$(cd po; x=(*.po); echo ${x[*]%.po})}" )
else
- myconf="${myconf} --disable-locale"
+ myeconfargs+=( LINGUAS= )
fi
- # default settings with $myconf appended
econf \
+ --localedir="${EPREFIX}"/usr/share/locale \
--sysconfdir="${EPREFIX}"/etc/X11 \
- --with-x \
+ --disable-static \
--enable-usermenu \
+ --with-{incs,libs}-from= \
--with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
- --localedir="${EPREFIX}"/usr/share/locale \
- ${myconf}
+ --with-x \
+ "${myeconfargs[@]}"
- pushd ../WindowMaker-extra-0.1 || die
+ pushd ../WindowMaker-extra-0.1 &>/dev/null || die
econf
}
@@ -88,18 +99,15 @@ src_compile() {
emake
# WindowMaker Extra Package (themes and icons)
- pushd ../WindowMaker-extra-0.1 || die
- emake
+ emake -C ../WindowMaker-extra-0.1
}
src_install() {
default
# WindowMaker Extra
- pushd ../WindowMaker-extra-0.1 || die
- emake DESTDIR="${D}" install
-
- newdoc README README.extra
+ emake -C ../WindowMaker-extra-0.1 DESTDIR="${D}" install
+ newdoc ../WindowMaker-extra-0.1/README README.extra
# create wmaker session shell script
echo "#!/usr/bin/env bash" > wmaker
@@ -110,4 +118,6 @@ src_install() {
insinto /usr/share/xsessions
doins "${FILESDIR}"/wmaker.desktop
make_desktop_entry /usr/bin/wmaker
+
+ find "${ED}" -type f -name '*.la' -delete || die
}