summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-01-07 19:10:54 -0500
committerMichał Górny <mgorny@gentoo.org>2021-01-12 19:33:34 +0100
commit833ca5702969a66822d9a7a129722e7d19365779 (patch)
treedc66ccc99360c4385b2ce3e96027ccd9d127510c /xfce-base/exo
parentmedia-video/vlc: change revision (diff)
downloadgentoo-833ca5702969a66822d9a7a129722e7d19365779.tar.gz
gentoo-833ca5702969a66822d9a7a129722e7d19365779.tar.bz2
gentoo-833ca5702969a66822d9a7a129722e7d19365779.zip
xfce-base/exo: support cross-compiling
An execution test in the configure script would fail when cross- compiling, so patch it to support a cache variable that is enabled by default. This requires installing the xfce-dev-tools package for autoconf macro definitions. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/exo-4.16.0.ebuild14
-rw-r--r--xfce-base/exo/files/exo-4.16.0-allow-cross.patch59
2 files changed, 71 insertions, 2 deletions
diff --git a/xfce-base/exo/exo-4.16.0.ebuild b/xfce-base/exo/exo-4.16.0.ebuild
index f67b97867965..96c225ee8e5d 100644
--- a/xfce-base/exo/exo-4.16.0.ebuild
+++ b/xfce-base/exo/exo-4.16.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit xdg-utils
+inherit autotools xdg-utils
DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
HOMEPAGE="https://www.xfce.org/projects/"
@@ -21,9 +21,19 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-util/gtk-doc-am
dev-util/intltool
+ dev-util/xfce4-dev-tools
sys-devel/gettext
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16.0-allow-cross.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_install() {
default
find "${D}" -name '*.la' -delete || die
diff --git a/xfce-base/exo/files/exo-4.16.0-allow-cross.patch b/xfce-base/exo/files/exo-4.16.0-allow-cross.patch
new file mode 100644
index 000000000000..098a0b23d645
--- /dev/null
+++ b/xfce-base/exo/files/exo-4.16.0-allow-cross.patch
@@ -0,0 +1,59 @@
+From c3e6d0a34d9b2be550994c39c264e3f96a2cc43a Mon Sep 17 00:00:00 2001
+From: David Michael <fedora.dm0@gmail.com>
+Date: Fri, 8 Jan 2021 18:35:16 -0500
+Subject: [PATCH] configure.ac: Allow cross-compiling
+
+AC_TRY_RUN fails by default when cross-compiling if it does not
+have the fourth parameter. This implements a new cache variable
+ac_cv_have_strftime_extension for that test which allows overriding
+the result to specify the target system behavior. It defaults to
+supporting the extension when cross-compiling.
+
+Signed-off-by: David Michael <fedora.dm0@gmail.com>
+---
+ configure.ac.in | 22 ++++++++++++++++------
+ 1 file changed, 16 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac.in b/configure.ac.in
+index b98fce6e..0483c8fa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -133,10 +133,16 @@
+ dnl ************************************
+ AC_FUNC_MMAP()
+
+-dnl ***************************************
+-dnl *** Check for strftime() extensions ***
+-dnl ***************************************
+-AC_TRY_RUN([
++dnl ***************************************************************************
++dnl *** Check for strftime() extensions ***
++dnl *** ***
++dnl *** AC_TRY_RUN must be able to build and execute programs natively on ***
++dnl *** the build system, so it fails when cross-compiling unless given an ***
++dnl *** action in the fourth parameter. This sets its results in a cache ***
++dnl *** variable that users can override to specify target system behavior. ***
++dnl ***************************************************************************
++AC_CACHE_CHECK([for strftime %E and %O modifiers],
++ [ac_cv_have_strftime_extension], [AC_TRY_RUN([
+ #include <string.h>
+ #include <time.h>
+ int
+@@ -149,9 +155,13 @@
+ return 0;
+ return 1;
+ }
+-], [
++ ],
++ [ac_cv_have_strftime_extension=yes],
++ [ac_cv_have_strftime_extension=no],
++ [ac_cv_have_strftime_extension=cross])])
++if test x"$ac_cv_have_strftime_extension" != x"no"; then
+ AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
+-])
++fi
+
+ dnl ******************************
+ dnl *** Check for i18n support ***
+--
+GitLab