summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-10 23:25:51 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-11 00:21:04 +0100
commitff7be8ebaf08d6f692f1546ce787a510d29b2772 (patch)
treec23ac6bf0727386c8a8a7a9b427a778cc75a984d /xfce-base/libxfce4ui
parentdev-python/jikanpy: 4.2.2 version bump (diff)
downloadgentoo-ff7be8ebaf08d6f692f1546ce787a510d29b2772.tar.gz
gentoo-ff7be8ebaf08d6f692f1546ce787a510d29b2772.tar.bz2
gentoo-ff7be8ebaf08d6f692f1546ce787a510d29b2772.zip
xfce-base/libxfce4ui: Bump to 4.15.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.15.6.ebuild73
-rw-r--r--xfce-base/libxfce4ui/metadata.xml1
3 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index b8648f4a1ed3..7ae4e520ae39 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -2,3 +2,4 @@ DIST libxfce4ui-4.14.1.tar.bz2 756175 BLAKE2B d487cc0a04b6053ead6670eeb83cafe1c4
DIST libxfce4ui-4.15.3.tar.bz2 756530 BLAKE2B ca2a9d5aae80d22a97b2fe932248756c9f34f71a13342670cdc0ad1c5393eb62d4f5bed8b21a45a60c762a83ebf1458deb7ef629c4dd3c894468ecf16a821dcf SHA512 a0e5a60c54df811fa2815238f9fe506700f6df8a6baa8172a6f8c68f005b54ba94ee31aba87d635fb506700da9c77e25f8c57268018fc8cfa5577f29aab58a6b
DIST libxfce4ui-4.15.4.tar.bz2 825895 BLAKE2B 46687dea72d17a3693c31f69bd4d1961397bf00d9395935778c8c5b90e6e56585fa2e64fe4be817ad44994841218d7cce98ade033914c56ea82a04ae7e1b70e7 SHA512 af2545f6d72df1a13d926a52b5124c52f34fbee0b2db6664292f74bcc3d93cb42263eab57beb9f882be42b6530649b2c7e42d496817f1b34b7d2b67b29e6deb1
DIST libxfce4ui-4.15.5.tar.bz2 813220 BLAKE2B 5925ea1e25abf485e04902b47da6e09d228297b7137dbeedb8c60655e2005ded37138d12482f8321928994f2bfb8d351bb18f2eb47f288d810f58ce75e378c06 SHA512 daa666826e2b4d876025a3c93b6caf40b063b456660116f5c4c8b2beb9a9eb26d6228785cc7e6435d2a38b68c15261fc872a8cf3e03af0969342e3396a6b2a49
+DIST libxfce4ui-4.15.6.tar.bz2 823475 BLAKE2B 11193a72be188dc205ad24d7ea06ac21f93679d58bed273d78ff04180226eab14fd211bd2feba9b3ade20539364f90229bdfe226c2b1e4b6f6a17f7444feb26d SHA512 608daf350b8fb43ae4eb70b6d7e684528bcc90360f6d29b182da4f04bc51f5c191e27369dfa1554b6840dbdefbe132cfc66935b6f2d88dcc62f67f929b9423ec
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.15.6.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.15.6.ebuild
new file mode 100644
index 000000000000..ba60530e9b5b
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.15.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.12:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ media-libs/libepoxy
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-base/libxfce4ui/metadata.xml b/xfce-base/libxfce4ui/metadata.xml
index b16ea0c2efba..b44a362a8f7f 100644
--- a/xfce-base/libxfce4ui/metadata.xml
+++ b/xfce-base/libxfce4ui/metadata.xml
@@ -9,5 +9,6 @@
<flag name="glade">Build support for Glade 3's GtkBuilder implementation</flag>
<flag name="gtk2">Build deprecated GTK+2 libxfce4ui-1 library.</flag>
<flag name="libgtop">Enable system information via <pkg>gnome-base/libgtop</pkg>.</flag>
+ <flag name="system-info">Enable system information in xfce4-about.</flag>
</use>
</pkgmetadata>