summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-11 19:42:06 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-11 19:45:09 +0200
commit10240489800855f4bc065420d7c929ce0b7605a7 (patch)
tree64998f7138c066c2de3434690df1693999f00c8f /xfce-base/libxfce4util
parentdev-util/xfce4-dev-tools: Bump to 4.14.0 (no changes) (diff)
downloadgentoo-10240489800855f4bc065420d7c929ce0b7605a7.tar.gz
gentoo-10240489800855f4bc065420d7c929ce0b7605a7.tar.bz2
gentoo-10240489800855f4bc065420d7c929ce0b7605a7.zip
xfce-base/libxfce4util: Bump to 4.14.0 (no changes)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.14.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 50d150fa4d8b..fa93d3b7f1df 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.13.2.tar.bz2 509280 BLAKE2B 40f1fb95abff4857e976dd5f3ae8c8ad5e66e2c1c49723735e85124db71d30f204525cd74baf22e31bf405718f378b0c9ac37ec4189e1f4b9941d0eb6fc141ce SHA512 3bbb718f3a6d2213c86695b3f99d1e67c859ce635e5d066b18745d2ee57c0b2eea468b61079d8e2514c2d8f5fa847539d236ec0ed3fd17fecd9d1b36dc3595c4
DIST libxfce4util-4.13.5.tar.bz2 501748 BLAKE2B 2faee4f20f8a28c207fb9c20c15db92d336c5e86d6d9c64596a6670f043ad4a551e6f18779f1b52419a41d1bfe1f3e80b4c073e630dabefc5de3cd3c80b3359b SHA512 a7b5f540adbbb81d6382072f3fac4d919bb3be691f647cd70a5b8ef026e64d68ff5a7e340bb75df999145702b7dfc1a6e493e6f635e3d64ab78bf8831082e565
+DIST libxfce4util-4.14.0.tar.bz2 516358 BLAKE2B d8e3d1e3247e23908456aa296415240c1a9146001a02cb859541922ee541e30955279fd68f2d9938e43f992a5115b21836363fa8d8234de87fca0bbaac830bf0 SHA512 6ac95aea03052d9e2f886cbe76afe9bbb43511bf3fe1766097e10cd8762541ed17060a727df3ef93e226aae448c15d9dd3ad8acd55a9d5f2387cb360bdf72832
diff --git a/xfce-base/libxfce4util/libxfce4util-4.14.0.ebuild b/xfce-base/libxfce4util/libxfce4util-4.14.0.ebuild
new file mode 100644
index 000000000000..eebcd790a572
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.14.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}