summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-19 14:49:00 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-19 15:22:55 +0200
commit9391119d30c034c44cd8011496004a81551c6685 (patch)
tree3edc091f0710a15c87a4def1f3b8071f52c62aaf /xfce-base/xfce4-settings
parentvirtual/perl-File-Path: add ~x64-cygwin keyword (diff)
downloadgentoo-9391119d30c034c44cd8011496004a81551c6685.tar.gz
gentoo-9391119d30c034c44cd8011496004a81551c6685.tar.bz2
gentoo-9391119d30c034c44cd8011496004a81551c6685.zip
xfce-base/xfce4-settings: Bump to 4.13.1 (compat with new xfconf)
Diffstat (limited to 'xfce-base/xfce4-settings')
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.13.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index c40d317ae8a8..eaec5462eb25 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-settings-4.12.0.tar.bz2 973324 SHA256 04becef105c19d0266cfe8dbf42619e7233c3b9fa99b43dbfc9c6a5959501f81 SHA512 4a61c16f1f03de98c9968a00b50595e2934aaf28b80613c59403d33a293a7f8ef9ebb6fad98b0eeb97a6590b9100e91f73dd6363133d5d8bd06714f1126d8856 WHIRLPOOL 52a66c1b99f67b1e92ccbc223535617a6edff67857032d7c19581fe38e4b5b7e2b32a42bb5263f92ec02596035dd76f6a8f6387f17e524b035def717eda373ff
DIST xfce4-settings-4.13.0.tar.bz2 1037084 SHA256 01a19a2d320617efc7de972069024f2a86255b8abf354fbd3698f361db75063d SHA512 ae9094ce0a2a85d7d38a72bbc355f5d06741ec5db16ebcfab74e7504f1ba17360d1fc3e38b357665c3bacf065c02cd6c12c2d1619a18523b42efb311877dfa62 WHIRLPOOL 60276d31fd689bf3f10980310e5c401a2551ea12e94451fde88577a21b6a5a04e240a0b86f8136ed084b1814db00dd1ce580f0f1cb0ab37d00bea0793e4ebce4
+DIST xfce4-settings-4.13.1.tar.bz2 1034276 SHA256 01b9e9df6801564b28f3609afee1628228cc24c0939555f60399e9675d183f7e SHA512 e108ccf306599716c2fbc0fc11cd0b05fc89909c51e3bc5513745ac0279432d93c690f9f8d7faeb4bd8ffbd1d7a271276b0f690040692ca2d3f3a1ac55b62ccd WHIRLPOOL 5ebfb9d862ac811394a5a4f15baf5dd2ef6b6ef64a98efa6e2f5b73168668ddbfdcd43b6649b02225ab067e05f31f0b618d24a93c4a9588fe693830de8df6ec1
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.13.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.13.1.ebuild
new file mode 100644
index 000000000000..e333ed8566d9
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.13.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="input_devices_libinput libcanberra libnotify upower +xklavier"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ media-libs/fontconfig
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/exo-0.11
+ >=xfce-base/libxfce4ui-4.12
+ >=xfce-base/libxfce4util-4.12
+ >=xfce-base/xfconf-4.13
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )
+ xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+src_configure() {
+ econf \
+ $(use_enable upower upower-glib) \
+ $(use_enable input_devices_libinput xorg-libinput) \
+ $(use_enable libnotify) \
+ $(use_enable xklavier libxklavier) \
+ $(use_enable libcanberra sound-settings)
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}