summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-17 20:26:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-17 20:26:17 +0200
commitfd43054b14e78072386d8d94533f09efe32e0539 (patch)
treeb41f76a04e6520d3b81e771e68b6094e309cef6c /xfce-base/xfdesktop
parentxfce-base/xfce4-appfinder: Bump to 4.13.3 (diff)
downloadgentoo-fd43054b14e78072386d8d94533f09efe32e0539.tar.gz
gentoo-fd43054b14e78072386d8d94533f09efe32e0539.tar.bz2
gentoo-fd43054b14e78072386d8d94533f09efe32e0539.zip
xfce-base/xfdesktop: Bump to 4.13.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.13.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 124a146f5af0..144a4f2ad913 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
DIST xfdesktop-4.12.4.tar.bz2 1421623 BLAKE2B a18b891d639165d617f2701106dedb2f8577273ece5a4c93f6b5e1ef26f801304ea2014f21bd2821eb9bac9b19e02dd75cd4054a116eefd544f4d8e5d6968879 SHA512 29f170b96836298dc83e3c49650ab7e88a93c1a2fa1599d1d98f3b6c80c9c059748b76a821077eea39b5b4619998bb300ff17f06e88483a59bd5ae2b76d0605e
DIST xfdesktop-4.13.3.tar.bz2 1487433 BLAKE2B 81c5be8d54da6bfdb121d5632d67abfe6705eeddfb8c247ebf6870261093908660f880c8152d0cff87c912b1f3277d6551993a6a64384e610928c9bc6fda45a9 SHA512 5d828ad653b46ab1edc8300335321bab48e0ad2be1ae02944eff553375a6059513aeb363c73aaec1a6958dd3f1c873920287ad911cfe7b8096b447f1b8165ce3
+DIST xfdesktop-4.13.4.tar.bz2 1485482 BLAKE2B c0f40c448d79e3840d8708e8c5fb4a1d94658ab866c630c5a9b2cd40e3b92b3598e57377ed60621a5b28daedd7ab877aeb13b84735a23f5a302cf07434008012 SHA512 3943fc2af3ca3996a38900fea4a03004e1d3f8728a8517c988bd59744607ed8e4ba3f135d6075833af206df3c35464633f47e374c26fcbb8a20f0f1ecfdb7da6
diff --git a/xfce-base/xfdesktop/xfdesktop-4.13.4.ebuild b/xfce-base/xfdesktop/xfdesktop-4.13.4.ebuild
new file mode 100644
index 000000000000..b4de135cc031
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.13.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12:=
+ >=dev-libs/glib-2.42:=
+ >=x11-libs/gtk+-3.22:3=
+ >=x11-libs/libwnck-3.14:3=
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? (
+ >=dev-libs/glib-2.38:=
+ >=xfce-base/thunar-1.7:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}