summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-30 22:34:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-30 23:00:34 +0200
commit717f9dc9d6b226e9fcf2dbf7921e4534177e8a6d (patch)
tree45276bcdd69eba375d19f14860f395855e97a7a5 /xfce-base/xfwm4
parentapp-crypt/nitrokey-app: Bump to version 1.4 (diff)
downloadgentoo-717f9dc9d6b226e9fcf2dbf7921e4534177e8a6d.tar.gz
gentoo-717f9dc9d6b226e9fcf2dbf7921e4534177e8a6d.tar.bz2
gentoo-717f9dc9d6b226e9fcf2dbf7921e4534177e8a6d.zip
xfce-base/xfwm4: Bump to 4.13.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfwm4')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.13.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index fce1ae9d719a..d89f4de9c61a 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,2 +1,3 @@
DIST xfwm4-4.12.5.tar.bz2 1215450 BLAKE2B 3a156af589ec7391245edbedbc6e10ac9c746121f68e4bd0c64e30b9b0c11abfe13c1fb77321249edd4e5c8d3051f62f135093fabfd8ba215573d330fd3745c2 SHA512 b723638b9cd858beb75232a251471cfb2d01ddb412b536c3f0b432e1f894014e1ad51c77d208d5439ae8a8d970344d0146d5f9475106c1b66d22715af7af42d9
DIST xfwm4-4.13.2.tar.bz2 1139976 BLAKE2B 724cb6562f89048f3f94740ff6984f2780274240800646050c62d0b19e303fcdfb1022227262953c09bb42a9a5a176dca8e1e69252d953df15660dd22f906ecb SHA512 85440a377cd7034e986b317e35c25ac6d4723bd4c1ce1e6951d8545a44f3c47340952fd0211f55cf19411539be6d86f4c34fca7b2219b0873654a6d311c95055
+DIST xfwm4-4.13.3.tar.bz2 1143136 BLAKE2B 3d39b9313e97350c8c914b772262be83aa87255521dfde3f9f57a669e855c31824b717a617d7cf6f0b858b6611475dbe256dec5c1708b967e114f4d3cff87f79 SHA512 cbd410c9a5a997be6582c9bcd0af879be2c6e5b5362c0e950bb1281b4d2f4a1acbf40b3da88fb8dea3b22f491b69bc3c6df4f75c09c8c36cf9c76a02b528785a
diff --git a/xfce-base/xfwm4/xfwm4-4.13.3.ebuild b/xfce-base/xfwm4/xfwm4-4.13.3.ebuild
new file mode 100644
index 000000000000..db4e29db4f92
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.13.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+RDEPEND="dev-libs/dbus-glib:=
+ >=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-3.20:3=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXinerama:=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/pango:=
+ >=x11-libs/libwnck-3.14:3=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification:= )
+ xpresent? ( x11-libs/libXpresent )
+ xcomposite? (
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXfixes:=
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xpresent)
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}