summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-27 13:21:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-27 13:26:17 +0200
commit129cf04243beb1f30079c0daf2145dcb5de0254e (patch)
tree4f891ec0376fa4ae93eedd67f111be04da811fd8 /xfce-base
parentapp-misc/vlock: Also block >=sys-apps/kbd-2.0.4-r1[pam] (diff)
downloadgentoo-129cf04243beb1f30079c0daf2145dcb5de0254e.tar.gz
gentoo-129cf04243beb1f30079c0daf2145dcb5de0254e.tar.bz2
gentoo-129cf04243beb1f30079c0daf2145dcb5de0254e.zip
xfce-base/exo: Bump to 0.12.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-0.12.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 38fbf2161c1a..896694f001b1 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,3 +1,4 @@
DIST exo-0.12.4.tar.bz2 1235738 BLAKE2B f05ae13bb5ec599686207df3fe7458b8a42227194c91c24397ed282d2c7a6ccf10989f14c662f2e0d986c59695de2b8d50743c8489bc716aaa001cbd23fe3598 SHA512 8f84258aeb5c1fcfe91e775af1e5fed02f36b3d18aa72d497cd05294d54f050d679628cdb4339219c67b203a8cc663704a240fc18e6a918cef363cf4d9b94783
DIST exo-0.12.5.tar.bz2 1236257 BLAKE2B e1ea6f63e1e64a4f098e03ab45f2ff21a3a3851dcafa314aaadea9fcbb00f790ab18d608b4920dac868a31048d618a67c7f69c7fd5bcd8ea187fea78d20f7d0b SHA512 00165ef85145603f59cc4188d2637ec51c8cc51d9f2288c4e5b0328a2b085e940fbaaa987bf5a51c9999184f2d4f6f9751f4304feb6143416bade826007b3bf6
DIST exo-0.12.6.tar.bz2 1288734 BLAKE2B 555e7d24f1ceac7b643baf99c37d2442fd7fedb231ba99da79c0ac70685166412007df5b9b60c4f192aa82f0de8c38c2b21a2ee3e4fdefe51975cab1978a6ed6 SHA512 468f8e95068135a08da58abd35e8b886864262550fe3860a8e61ed6376783491139ae837427e0cabfe9b46184b339e482f0e9a9c9c8439c695d4268c94b5e405
+DIST exo-0.12.7.tar.bz2 1342229 BLAKE2B 992314cd036f618958ff687cdad09a8bd8efcfb4d2aced08da012a239cb7811594bbdd3e3066633cc6d2972b88533fbcdfe41ee25d7c6aa68ed03a6f31a4a11d SHA512 482f75f17f6d8d9bbbb6a7ddd256e0b6fbe8663bc7ddfc3466c429bfdeff4f484622fe45ccea7fe7f93708464f5d51ff9daf2e010d46b6124d21a808b980d46f
diff --git a/xfce-base/exo/exo-0.12.7.ebuild b/xfce-base/exo/exo-0.12.7.ebuild
new file mode 100644
index 000000000000..8c2eea9c5c24
--- /dev/null
+++ b/xfce-base/exo/exo-0.12.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="gtk2"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42:=
+ dev-perl/URI
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ gtk2? ( >=x11-libs/gtk+-2.24:2= )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable gtk2)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}